summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 21:07:22 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 21:29:03 -0500
commitcecb025583a6a4abf34f64c1b52aed7bc154e573 (patch)
tree4b5d8474e3066bc5b058d07269afa72b9e565510
parent7f94e81a13654cd3c9801ac0c78a485d51669e35 (diff)
build-system: pyproject: Add allowed/disallowed keyword arguments.
* gnu/build-system/pyproject.scm (pyproject-build) Add ALLOWED-REFERENCES and DISALLOWED-REFERENCES keywords. Change-Id: I404cbd8409332705b023c7a3b0b8fafbfaefe28b
-rw-r--r--guix/build-system/pyproject.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/guix/build-system/pyproject.scm b/guix/build-system/pyproject.scm
index 2a2c3af3f3..9a27ebee35 100644
--- a/guix/build-system/pyproject.scm
+++ b/guix/build-system/pyproject.scm
@@ -98,7 +98,9 @@
(guile #f)
(imported-modules %pyproject-build-system-modules)
(modules '((guix build pyproject-build-system)
- (guix build utils))))
+ (guix build utils)))
+ allowed-references
+ disallowed-references)
"Build SOURCE using PYTHON, and with INPUTS."
(define build
(with-imported-modules imported-modules
@@ -131,7 +133,9 @@
#:system system
#:graft? #f ;consistent with 'gnu-build'
#:target #f
- #:guile-for-build guile)))
+ #:guile-for-build guile
+ #:allowed-references allowed-references
+ #:disallowed-references disallowed-references)))
(define pyproject-build-system
(build-system