summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-17 13:18:35 +0200
committerChristopher Baines <mail@cbaines.net>2024-06-29 12:13:16 +0100
commitd0ec5f8e5ae1464d2d8ad516cfc2174fe2faa4ed (patch)
tree167b829dce619f35a2169f55766a9926db133640
parent6d134c4c2efafd46a76d1826b135a0960f4abe71 (diff)
gnu: TeX Live packages built from TEXLIVE-SOURCE use same version.
* gnu/packages/tex.scm (%texlive-version): New variable. (texlive-source): (texlive-libkpathsea)[version]: (texlive-libptexenc)[version]: (texlive-bin)[version]: (texlive-scheme-basic)[version]: (texlive-scheme-bookpub)[version]: (texlive-scheme-context)[version]: (texlive-scheme-full)[version]: (texlive-scheme-gust)[version]: (texlive-scheme-medium)[version]: (texlive-scheme-minimal)[version]: (texlive-scheme-small)[version]: (texlive-scheme-tetex)[version]: (texlive-collection-basic)[version]: (texlive-collection-bibtexextra)[version]: (texlive-collection-binextra)[version]: (texlive-collection-context)[version]: (texlive-collection-fontsextra)[version]: (texlive-collection-fontsrecommended)[version]: (texlive-collection-fontutils)[version]: (texlive-collection-formatsextra)[version]: (texlive-collection-games)[version]: (texlive-collection-humanities)[version]: (texlive-collection-langarabic)[version]: (texlive-collection-langchinese)[version]: (texlive-collection-langcjk)[version]: (texlive-collection-langcyrillic)[version]: (texlive-collection-langczechslovak)[version]: (texlive-collection-langenglish)[version]: (texlive-collection-langeuropean)[version]: (texlive-collection-langfrench)[version]: (texlive-collection-langgerman)[version]: (texlive-collection-langgreek)[version]: (texlive-collection-langitalian)[version]: (texlive-collection-langjapanese)[version]: (texlive-collection-langkorean)[version]: (texlive-collection-langother)[version]: (texlive-collection-langpolish)[version]: (texlive-collection-langportuguese)[version]: (texlive-collection-langspanish)[version]: (texlive-collection-latex)[version]: (texlive-collection-latexextra)[version]: (texlive-collection-latexrecommended)[version]: (texlive-collection-luatex)[version]: (texlive-collection-mathscience)[version]: (texlive-collection-metapost)[version]: (texlive-collection-music)[version]: (texlive-collection-pictures)[version]: (texlive-collection-plaingeneric)[version]: (texlive-collection-pstricks)[version]: (texlive-collection-publishers)[version]: (texlive-collection-xetex)[version]: Use new variable. * guix/import/texlive.scm (tlpdb->package): Always use version from %TEXLIVE-VERSION. * tests/texlive.scm ("texlive->guix-package, meta-package"): Test change to importer. Since meta-packages are empty, they are not going through an updater. This change makes sure they always refer to an up-to-date version when the rest of TeX Live is updated. Change-Id: I55445e3337c1dea22158103d9ed952f75c3c4964 texlive-source Change-Id: I198a361fd6df3c5dd2b4fa376e1ad623937f08cc
-rw-r--r--gnu/packages/tex.scm111
-rw-r--r--guix/import/texlive.scm2
-rw-r--r--tests/texlive.scm2
3 files changed, 58 insertions, 57 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 92264cfac9..bd495c18f4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -194,14 +194,15 @@
(define-deprecated/public old-name name
(deprecated-package (symbol->string 'old-name) name)))
+(define %texlive-version "2023.0")
+
(define texlive-source
(origin
(method svn-fetch)
(uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Build/source/"))
+ (url "svn://www.tug.org/texlive/trunk/Build/source/")
(revision %texlive-revision)))
- (file-name (string-append "texlive-source-" %texlive-tag "-checkout"))
+ (file-name (git-file-name "texlive-source" %texlive-version))
(sha256
(base32
"186q0r00zfd39wc9r56rvbxs8f1xix7hlrz62zj07c68a0fy76rd"))))
@@ -209,7 +210,7 @@
(define-public texlive-libkpathsea
(package
(name "texlive-libkpathsea")
- (version "2023.0")
+ (version %texlive-version)
(source
(origin
(inherit texlive-source)
@@ -310,7 +311,7 @@ of user-specified directories similar to how shells look up executables.")
(define-public texlive-libptexenc
(package
(name "texlive-libptexenc")
- (version "2023.0")
+ (version %texlive-version)
(source
(origin
(inherit texlive-source)
@@ -378,7 +379,7 @@ of user-specified directories similar to how shells look up executables.")
(method svn-multi-fetch)
(uri (svn-multi-reference
(url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/"))
+ "texlive-" version "/Master/"))
(locations
(list "texmf-dist/doc/man/man1/fmtutil-sys.1"
"texmf-dist/doc/man/man1/fmtutil-sys.man1.pdf"
@@ -749,7 +750,7 @@ and should be preferred to it whenever a package would otherwise depend on
(define-public texlive-bin
(package
(name "texlive-bin")
- (version "2023.0")
+ (version %texlive-version)
(source
(origin
(inherit texlive-source)
@@ -882,7 +883,7 @@ Live collection or scheme package to their profile instead of this package.")
(define-public texlive-scheme-basic
(package
(name "texlive-scheme-basic")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -901,7 +902,7 @@ Computer Modern fonts. This scheme corresponds to @code{collection-basic} and
(define-public texlive-scheme-bookpub
(package
(name "texlive-scheme-bookpub")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -945,7 +946,7 @@ mathematical or other technical packages.")
(define-public texlive-scheme-context
(package
(name "texlive-scheme-context")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -979,7 +980,7 @@ mathematical or other technical packages.")
(define-public texlive-scheme-full
(package
(name "texlive-scheme-full")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -1032,7 +1033,7 @@ mathematical or other technical packages.")
(define-public texlive-scheme-gust
(package
(name "texlive-scheme-gust")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -1079,7 +1080,7 @@ typeset Polish plain TeX, LaTeX and ConTeXt documents in PostScript or PDF.")
(define-public texlive-scheme-medium
(package
(name "texlive-scheme-medium")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -1115,7 +1116,7 @@ LaTeX, many recommended packages, and support for most European languages.")
(define-public texlive-scheme-minimal
(package
(name "texlive-scheme-minimal")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -1132,7 +1133,7 @@ Live infrastructure. This scheme corresponds exactly to
(define-public texlive-scheme-small
(package
(name "texlive-scheme-small")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -1182,7 +1183,7 @@ variant. It adds XeTeX, MetaPost, and some recommended packages to
(define-public texlive-scheme-tetex
(package
(name "texlive-scheme-tetex")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -66100,7 +66101,7 @@ The macros were designed for use within other macros.")
(define-public texlive-collection-basic
(package
(name "texlive-collection-basic")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -66150,7 +66151,7 @@ LaTeX.")
(define-public texlive-collection-bibtexextra
(package
(name "texlive-collection-bibtexextra")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -66329,7 +66330,7 @@ data(bases), notably including BibLaTeX.")
(define-public texlive-collection-binextra
(package
(name "texlive-collection-binextra")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -66450,7 +66451,7 @@ programming, patgen, and plenty more.")
(define-public texlive-collection-context
(package
(name "texlive-collection-context")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -66500,7 +66501,7 @@ third-party ConTeXt packages.")
(define-public texlive-collection-fontsextra
(package
(name "texlive-collection-fontsextra")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -66862,7 +66863,7 @@ third-party ConTeXt packages.")
(define-public texlive-collection-fontsrecommended
(package
(name "texlive-collection-fontsrecommended")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -66912,7 +66913,7 @@ for Computer Modern, in outline form.")
(define-public texlive-collection-fontutils
(package
(name "texlive-collection-fontutils")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -66948,7 +66949,7 @@ for manipulation of PostScript and other image formats.")
(define-public texlive-collection-formatsextra
(package
(name "texlive-collection-formatsextra")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -66987,7 +66988,7 @@ HiTeX engine and related.")
(define-public texlive-collection-games
(package
(name "texlive-collection-games")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67050,7 +67051,7 @@ including chess.")
(define-public texlive-collection-humanities
(package
(name "texlive-collection-humanities")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67118,7 +67119,7 @@ humanities, etc.")
(define-public texlive-collection-langarabic
(package
(name "texlive-collection-langarabic")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67160,7 +67161,7 @@ humanities, etc.")
(define-public texlive-collection-langchinese
(package
(name "texlive-collection-langchinese")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67208,7 +67209,7 @@ from @code{collection-langcjk}.")
(define-public texlive-collection-langcjk
(package
(name "texlive-collection-langcjk")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67244,7 +67245,7 @@ their individual language collections.")
(define-public texlive-collection-langcyrillic
(package
(name "texlive-collection-langcyrillic")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67296,7 +67297,7 @@ Russian, Serbian, Ukrainian), even if Latin alphabets may also be used.")
(define-public texlive-collection-langczechslovak
(package
(name "texlive-collection-langczechslovak")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67324,7 +67325,7 @@ Russian, Serbian, Ukrainian), even if Latin alphabets may also be used.")
(define-public texlive-collection-langenglish
(package
(name "texlive-collection-langenglish")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67408,7 +67409,7 @@ Russian, Serbian, Ukrainian), even if Latin alphabets may also be used.")
(define-public texlive-collection-langeuropean
(package
(name "texlive-collection-langeuropean")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67471,7 +67472,7 @@ simply on the size of the support.")
(define-public texlive-collection-langfrench
(package
(name "texlive-collection-langfrench")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67527,7 +67528,7 @@ simply on the size of the support.")
(define-public texlive-collection-langgerman
(package
(name "texlive-collection-langgerman")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67583,7 +67584,7 @@ simply on the size of the support.")
(define-public texlive-collection-langgreek
(package
(name "texlive-collection-langgreek")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67621,7 +67622,7 @@ simply on the size of the support.")
(define-public texlive-collection-langitalian
(package
(name "texlive-collection-langitalian")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67652,7 +67653,7 @@ simply on the size of the support.")
(define-public texlive-collection-langjapanese
(package
(name "texlive-collection-langjapanese")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67730,7 +67731,7 @@ from @code{collection-langcjk}.")
(define-public texlive-collection-langkorean
(package
(name "texlive-collection-langkorean")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67758,7 +67759,7 @@ from @code{collection-langcjk}.")
(define-public texlive-collection-langother
(package
(name "texlive-collection-langother")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67825,7 +67826,7 @@ reasonable.")
(define-public texlive-collection-langpolish
(package
(name "texlive-collection-langpolish")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67856,7 +67857,7 @@ reasonable.")
(define-public texlive-collection-langportuguese
(package
(name "texlive-collection-langportuguese")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67881,7 +67882,7 @@ reasonable.")
(define-public texlive-collection-langspanish
(package
(name "texlive-collection-langspanish")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67904,7 +67905,7 @@ reasonable.")
(define-public texlive-collection-latex
(package
(name "texlive-collection-latex")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -67976,7 +67977,7 @@ used and strongly recommended in practice.")
(define-public texlive-collection-latexextra
(package
(name "texlive-collection-latexextra")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -69460,7 +69461,7 @@ LaTeX.")
(define-public texlive-collection-latexrecommended
(package
(name "texlive-collection-latexrecommended")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -69548,7 +69549,7 @@ LaTeX which have widespread use.")
(define-public texlive-collection-luatex
(package
(name "texlive-collection-luatex")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -69660,7 +69661,7 @@ itself, and plain formats, are in @code{collection-basic}.")
(define-public texlive-collection-mathscience
(package
(name "texlive-collection-mathscience")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -69925,7 +69926,7 @@ science packages.")
(define-public texlive-collection-metapost
(package
(name "texlive-collection-metapost")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -69987,7 +69988,7 @@ with packages in @code{collection-basic}.")
(define-public texlive-collection-music
(package
(name "texlive-collection-music")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -70036,7 +70037,7 @@ with packages in @code{collection-basic}.")
(define-public texlive-collection-pictures
(package
(name "texlive-collection-pictures")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -70290,7 +70291,7 @@ PStricks are separate.")
(define-public texlive-collection-plaingeneric
(package
(name "texlive-collection-plaingeneric")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -70415,7 +70416,7 @@ often LaTeX, and occasionally other formats.")
(define-public texlive-collection-pstricks
(package
(name "texlive-collection-pstricks")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -70543,7 +70544,7 @@ often LaTeX, and occasionally other formats.")
(define-public texlive-collection-publishers
(package
(name "texlive-collection-publishers")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
@@ -70833,7 +70834,7 @@ often LaTeX, and occasionally other formats.")
(define-public texlive-collection-xetex
(package
(name "texlive-collection-xetex")
- (version (number->string %texlive-revision))
+ (version %texlive-version)
(source #f)
(build-system trivial-build-system)
(arguments (list #:builder #~(mkdir #$output)))
diff --git a/guix/import/texlive.scm b/guix/import/texlive.scm
index b743495008..0fba171f46 100644
--- a/guix/import/texlive.scm
+++ b/guix/import/texlive.scm
@@ -570,7 +570,7 @@ at VERSION."
(values
`(package
(name ,name)
- (version ,version)
+ (version ,(if empty-package? '%texlive-version version))
(source ,(and (not meta-package?)
`(texlive-origin
name version
diff --git a/tests/texlive.scm b/tests/texlive.scm
index 427d4b2cf7..39f7a8f856 100644
--- a/tests/texlive.scm
+++ b/tests/texlive.scm
@@ -561,7 +561,7 @@ completely compatible with Plain TeX.")
(match result
(('package
('name "texlive-collection-texworks")
- ('version _)
+ ('version '%texlive-version)
('source #f)
('build-system 'trivial-build-system)
('arguments