summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-05 08:43:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-05 08:57:53 +0100
commitd2a6480e8e7156a14f834a21af01f164ab16a624 (patch)
treea984c5cd3557ff0f8a1488414cd0284af9d2e922
parent036d2fc88afb641a5765dd57308a8bd228c7575c (diff)
gnu: Add r-scrnaseq.
* gnu/packages/bioconductor.scm (r-scrnaseq): New variable. Change-Id: Iee25b59af0000f4d2fd7482183b43404840a336c
-rw-r--r--gnu/packages/bioconductor.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1ea5e47321..bf38afb762 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018, 2020, 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
@@ -10510,6 +10510,38 @@ expression information. The package functions as a wrapper for Startrac and
powerTCR R packages.")
(license license:gpl2)))
+(define-public r-scrnaseq
+ (package
+ (name "r-scrnaseq")
+ (version "2.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "scRNAseq" version
+ 'experiment))
+ (sha256
+ (base32 "0dbh3sqq7lkkdf7vls5qg7fbn6y74c7hsigb4d69pvk934ll88aw"))))
+ (properties `((upstream-name . "scRNAseq")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-annotationdbi
+ r-annotationhub
+ r-biocgenerics
+ r-ensembldb
+ r-experimenthub
+ r-genomicfeatures
+ r-genomicranges
+ r-s4vectors
+ r-singlecellexperiment
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/scRNAseq")
+ (synopsis "Collection of public single-cell RNA-seq datasets")
+ (description
+ "This package contains gene-level counts for a collection of public
+@code{scRNA-seq} datasets, provided as @code{SingleCellExperiment} objects
+with cell- and gene-level metadata.")
+ (license license:cc0)))
+
(define-public r-scry
(package
(name "r-scry")