summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCayetano Santos <csantosb@inventati.org>2023-08-09 16:42:15 +0200
committerLudovic Courtès <ludo@gnu.org>2023-08-12 23:08:51 +0200
commitd31a3d4d1295176e97e7ba5793ae6037739b30ff (patch)
tree07b97bf9345d891908fd209af55080a245775e30
parent9be28375cf6d900e075b470412d629ddbd8710c0 (diff)
gnu: Add emacs-math-preview.
* gnu/packages/emacs-xyz.scm (emacs-math-preview): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 53c116c252..0f0751e39a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9052,6 +9052,30 @@ completion candidate when using the Company text completion framework.")
@code{company-math}.")
(license license:gpl3+)))
+(define-public emacs-math-preview
+ (package
+ (name "emacs-math-preview")
+ (version "5.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://gitlab.com/matsievskiysv/math-preview")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ni08900p0pbajw143iw0b7a62qiqcm9b6jy7pqgpn437vydjx1z"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-dash emacs-s))
+ (home-page "https://gitlab.com/matsievskiysv/math-preview")
+ (synopsis "Preview TeX math equations inline using MathJax")
+ (description
+ "Emacs math-preview uses MathJax for displaying TeX, MathML and AsciiMath
+ math inline in Emacs buffers.")
+ (license license:gpl3+)))
+
(define-public emacs-company-coq
(package
(name "emacs-company-coq")