summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-08 10:22:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-08 10:37:08 +0200
commitd3934c7cc250cf9bc539504fcdb7cd3717b8a6bd (patch)
tree1593fafbb7c1a6547ccbcfa6b3b76eca74308686
parent7a78dd1e39bd6e9a41047f28a101e9c1baf29a86 (diff)
gnu: Add python-pathy.
* gnu/packages/python-xyz.scm (python-pathy): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cb323b5279..98abf038a5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9441,6 +9441,28 @@ all the newest features of the standard @code{pathlib} can be used also on
older Python versions.")
(license license:expat)))
+(define-public python-pathy
+ (package
+ (name "python-pathy")
+ (version "0.10.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pathy" version))
+ (sha256
+ (base32
+ "12v196q3rai33cfzrmb9pqfqv7ailngssjdrzdf8gzym9hdygmjc"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-dataclasses python-smart-open python-typer))
+ (native-inputs (list python-mock python-pytest))
+ (home-page "https://github.com/justindujardin/pathy")
+ (synopsis "Path interface for local and cloud bucket storage")
+ (description "Pathy is a python package (with type annotations) for
+working with Cloud Bucket storage providers using a @code{pathlib} interface.
+It provides @code{pathlib.Path} subclasses for local and cloud bucket
+storage.")
+ (license license:asl2.0)))
+
(define-public python-importlib-resources
(package
(name "python-importlib-resources")