summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-17 16:36:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-22 18:54:58 +0200
commitd4b83651d1331ebe5327d0d448567f3084bdd8b5 (patch)
tree1d244c3d1f7d6e4095a881f24f74c93fae8aa29d
parentfd3782d13b8f2e835e9867c7abd92786a93e8ad6 (diff)
gnu: Add r-aroma-light.
* gnu/packages/bioinformatics.scm (r-aroma-light): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9b4afbfcfb..a372b163cf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8994,6 +8994,33 @@ algorithms; density clustering, hierarchical clustering, k-means, and the
discovery of differentially expressed genes and markers.")
(license license:gpl3))))
+(define-public r-aroma-light
+ (package
+ (name "r-aroma-light")
+ (version "3.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "aroma.light" version))
+ (sha256
+ (base32
+ "10snykmmx36qaymyf5s1n1km8hsscyzpykcpf0mzsrcv8ml9rp8a"))))
+ (properties `((upstream-name . "aroma.light")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrixstats" ,r-matrixstats)
+ ("r-r-methodss3" ,r-r-methodss3)
+ ("r-r-oo" ,r-r-oo)
+ ("r-r-utils" ,r-r-utils)))
+ (home-page "https://github.com/HenrikBengtsson/aroma.light")
+ (synopsis "Methods for normalization and visualization of microarray data")
+ (description
+ "This package provides methods for microarray analysis that take basic
+data types such as matrices and lists of vectors. These methods can be used
+standalone, be utilized in other packages, or be wrapped up in higher-level
+classes.")
+ (license license:gpl2+)))
+
(define htslib-for-sambamba
(let ((commit "2f3c3ea7b301f9b45737a793c0b2dcf0240e5ee5"))
(package