summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-03-02 23:25:06 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:31 +0000
commitd7abe61507572f040cefe788a6853dbd5959e205 (patch)
treea5ec3d9d6bc74f5f0cd806544dbd8664d503f01e
parent496e0f10b63a3218cfc86804c8eb38b4d77acd8e (diff)
gnu: Add go-github-com-hashicorp-errwrap.
* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-errwrap): New variable. Change-Id: I4a0e7c23f9aaab4e29c81a68d976dafcd86dd2d1 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3fdc88c356..f488b17e61 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -768,6 +768,30 @@ Differentiation between text and binary files}.
@end itemize")
(license license:expat)))
+(define-public go-github-com-hashicorp-errwrap
+ (package
+ (name "go-github-com-hashicorp-errwrap")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/errwrap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0p5wdz8p7dmwphmb33gwhy3iwci5k9wkfqmmfa6ay1lz0cqjwp7a"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/errwrap"))
+ (home-page "https://github.com/hashicorp/errwrap")
+ (synopsis "Wrapping and querying errors for Golang")
+ (description
+ "@code{errwrap} is a package for Go that formalizes the pattern of
+wrapping errors and checking if an error contains another error.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-hhrutter-tiff
(package
(name "go-github-com-hhrutter-tiff")