summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2024-02-24 11:50:34 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2024-02-24 11:50:34 +0100
commitde24aaf13b17d6c019f3f240fd0eb0e1b8654970 (patch)
treecd2e5e6d8f78ccb3f6cd47d0f635eea6551577ce
parentad08af2fea53f728ec001b9dfcd36fecb73c848e (diff)
gnu: Add emacs-back-button.
* gnu/packages/emacs-xyz.scm (emacs-back-button): New variable. Change-Id: Ib020eab882f2ffa91a0fd02fefbe6629b80bd5ae
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1cf03a8183..8038c5d2c0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -39519,6 +39519,26 @@ specified in RFC 6238. It supports reading secrets in HEX and multiple base32
variations, including non-standard base32 encodings.")
(license license:gpl3+))))
+(define-public emacs-back-button
+ (package
+ (name "emacs-back-button")
+ (version "0.6.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rolandwalker/back-button.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hmn3jlsqgpc602lbcs9wzw0hgr5qpjdcxi2hjlc1cp27ilyscnf"))))
+ (build-system emacs-build-system)
+ (synopsis "Visual navigation through mark rings in Emacs")
+ (description "This package provides a way for the user to navigate
+through mark rings (in both directions, and globally or locally).")
+ (home-page "https://www.emacswiki.org/emacs/BackButton")
+ (license license:bsd-2)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar