summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:55:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:40 +0200
commitde87aca007500a5885e71a79cf50a0281b18419a (patch)
treed459679ec6d8e93b1323956a509994befaa9416b
parent6090dd9635cc99b6a366dbbde16250cefcd3bf9a (diff)
gnu: Add texlive-recycle.
* gnu/packages/tex.scm (texlive-recycle): New variable.
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9ecbf79b63..f6ea129d68 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -22193,6 +22193,37 @@ for recorders in both C and F, along with methods to create and display
alternate fingerings for trills, etc.")
(license license:lppl1.3+)))
+(define-public texlive-recycle
+ (package
+ (name "texlive-recycle")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/recycle/"
+ "fonts/map/dvips/recycle/"
+ "fonts/source/public/recycle/"
+ "fonts/tfm/public/recycle/"
+ "fonts/type1/public/recycle/"
+ "tex/latex/recycle/")
+ (base32
+ "16kmi7a75vrv3pfnxydxb21pafvi98q39jrdd10a94vxx6fdlx7s")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ ;; FIXME: Font metrics generation fails with "! Inconsistent equation (off
+ ;; by 0.00162)." errors.
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (delete 'generate-font-metrics))))
+ (native-inputs (list texlive-metafont))
+ (home-page "https://ctan.org/pkg/recycle")
+ (synopsis "Font providing the ``recyclable'' logo")
+ (description
+ "This single-character font is provided as Metafont source, and in Adobe
+Type 1 format. It is accompanied by a trivial LaTeX package to use the logo
+at various sizes.")
+ (license license:gpl3+)))
+
(define-public texlive-reledmac
(package
(name "texlive-reledmac")