summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-07-20 10:28:30 +0200
committerLudovic Courtès <ludo@gnu.org>2022-08-05 00:14:30 +0200
commite2397e66e6d6f0d67152b87b7ec8debee3687c53 (patch)
tree761c3cca4cb43e7af9945b452fda3cd4a0c2eba6
parentb7bbb77c9dd71fe805752c885a7191e5af31e4ec (diff)
gnu: Add lkrg.
* gnu/packages/linux.scm (lkrg): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b33fc244b2..aeb03020ce 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -60,7 +60,7 @@
;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
;;; Copyright © 2021 Olivier Dion <olivier.dion@polymtl.ca>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
-;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
@@ -1342,6 +1342,37 @@ battery charging thresholds, keyboard backlight, fans and thermal monitors,
and the notification, WiFi, and Bluetooth LED.")
(license license:gpl2)))
+(define-public lkrg
+ (package
+ (name "lkrg")
+ (version "0.9.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lkrg-org/lkrg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yirb7n4mqv8cn0gziz1m7ymq00dhhy79j59jdgrx00b8rj57cfw"))))
+ (build-system linux-module-build-system)
+ (arguments
+ (list #:linux linux-libre
+ #:tests? #f
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "SYSSRC="
+ (assoc-ref %build-inputs
+ "linux-module-builder")
+ "/lib/modules/build"))))
+ (inputs (list bash-minimal))
+ (home-page "https://lkrg.org/")
+ (synopsis "Linux Kernel Runtime Guard")
+ (description
+ "This package performs runtime integrity checking of the Linux kernel and
+detection of security vulnerability exploits against the kernel.")
+ (license license:gpl2)))
+
(define-public rtl8821ce-linux-module
(let ((commit "be733dc86781c68571650b395dd0fa6b53c0a039")
(revision "6"))