summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-11-04 15:02:32 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-04 22:26:37 +0100
commite30385d8d7045ad6abe75351228ff5c3cefd1209 (patch)
treea18b325c92e78925d9218de69bd548cd7b186282
parentbbb33a12fecdf4be98f09fba62e84c91d545fe31 (diff)
gnu: Add python-npx.
* gnu/packages/python-xyz.scm (python-npx): New variable. Change-Id: I9520ce12a936c68d38f2ac706165eff816d8b1ad Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6552ddba88..feecbc2aab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7466,6 +7466,28 @@ capabilities.")
(description "This package provides the complete NumPy documentation in
the Texinfo, HTML, and PDF formats.")))
+(define-public python-npx
+ (package
+ (name "python-npx")
+ (version "0.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "npx" version))
+ (sha256
+ (base32
+ "1m0v2p5mh3aqrypl4ipgzvr5nhx7bk5vv9ah2xr9l1xgj6nnmqnc"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy))
+ (native-inputs (list python-flit-core python-networkx python-pytest))
+ (home-page "https://github.com/nschloe/npx")
+ (synopsis "Extensions for NumPy")
+ (description "NumPy is a large library used everywhere in scientific
+computing. That's why breaking backwards-compatibility comes at a
+significant cost and is almost always avoided, even if the API of some
+methods is arguably lacking. This package provides drop-in wrappers
+\"fixing\" those.")
+ (license license:bsd-3)))
+
(define-public python-munch
(package
(name "python-munch")