summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 22:59:01 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:31 +0000
commite6ce91d1bf610baba201d9d81557d79baa15ccd8 (patch)
treed3df59763a76cca24bdbe8511c95d6108c84bdab
parentb577550c0026b27c0493480cac7852881eec4116 (diff)
gnu: go-github-com-hashicorp-go-syslog: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-hashicorp-go-syslog): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Iae1acbde5fcccb7879944dbcbda8a32672478f6a
-rw-r--r--gnu/packages/golang-xyz.scm24
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 08c3df44b5..05f32ad2e4 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -820,6 +820,30 @@ the functions @code{As}, @code{Is}, and @code{Unwrap}. This provides a
standardized approach for introspecting on error values.")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-go-syslog
+ (package
+ (name "go-github-com-hashicorp-go-syslog")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-syslog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09vccqggz212cg0jir6vv708d6mx0f9w5bxrcdah3h6chgmal6v1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-syslog"))
+ (home-page "https://github.com/hashicorp/go-syslog")
+ (synopsis "Golang syslog wrapper, cross-compile friendly")
+ (description
+ "This package is a very simple wrapper around log/syslog")
+ (license license:expat)))
+
(define-public go-github-com-hhrutter-tiff
(package
(name "go-github-com-hhrutter-tiff")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fbf6b4c349..4382b12f7c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8781,28 +8781,6 @@ is unchanged. This package contains a series of small enhancements and
additions.")
(license license:bsd-3))))
-(define-public go-github-com-hashicorp-go-syslog
- (package
- (name "go-github-com-hashicorp-go-syslog")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hashicorp/go-syslog")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "09vccqggz212cg0jir6vv708d6mx0f9w5bxrcdah3h6chgmal6v1"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/hashicorp/go-syslog"))
- (home-page "https://github.com/hashicorp/go-syslog")
- (synopsis "Golang syslog wrapper, cross-compile friendly")
- (description "This package is a very simple wrapper around log/syslog")
- (license license:expat)))
-
(define-public go-golang-zx2c4-com-wireguard
(package
(name "go-golang-zx2c4-com-wireguard")