summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2023-08-05 11:01:51 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:42 +0100
commite6efce9d4b760db544cfa0bd92bc6ab553d4b5f9 (patch)
treeccc8d6d5b864d9e529ca7a6dd0d5ffc4865ac75c
parentc973dc2d64212d814eabce734a5694f896e78f76 (diff)
gnu: Add go-github-com-pkg-profile.
* gnu/packages/golang-check.scm (go-github-com-pkg-profile): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I135b3f0ccadd27847a5745a71d75ec6c5b4d2b9e
-rw-r--r--gnu/packages/golang-check.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 1f76068c3e..4984d552d3 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -638,6 +638,44 @@ Gomega matcher library.")
framework.")
(license license:expat)))
+(define-public go-github-com-pkg-profile
+ (package
+ (name "go-github-com-pkg-profile")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/profile")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ifr9gnycjwh7dbvsb5vgs9kzlr548cb4m45zvl8i8lgd3qhppy1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; XXX: Unit tests failing, see
+ ;; <https://github.com/pkg/profile/issues/68>.
+ #:tests? #f
+ #:import-path "github.com/pkg/profile"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; profile drops a cpu.pprof file inside its source directory
+ ;; after tests which makes it unreproducible so we remove it.
+ (add-after 'check 'delete-test-file
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (delete-file (string-append "src/" import-path
+ "/cpu.pprof"))))))))
+ (propagated-inputs
+ (list go-github-com-felixge-fgprof))
+ (home-page "https://github.com/pkg/profile")
+ (synopsis "Simple profiling for Go")
+ (description
+ "Profile provides a simple way to manage runtime/pprof profiling of your
+Go application.")
+ (license license:bsd-2)))
+
(define-public go-github-com-prashantv-gostub
(package
(name "go-github-com-prashantv-gostub")