summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndre A. Gomes <andremegafone@gmail.com>2024-04-15 22:59:23 +0300
committerGuillaume Le Vaillant <glv@posteo.net>2024-04-18 10:02:44 +0200
commite9481f6ce5a9c20f652e5718d472b3ec7b93bddb (patch)
treef4555e001e8afe7fefd92f255059dd21a7828a08
parent2126dab4cd81db4cbde4566d8c638e45a4c0077c (diff)
gnu: cl-colors2: Update to 0.6.0.
* gnu/packages/lisp-xyz.scm (sbcl-cl-colors2): Update to 0.6.0. [inputs]: Add sbcl-parse-number. Change-Id: I954aa3eebff9da0d8749df1c7844982f8171d1d0 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm46
1 files changed, 22 insertions, 24 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5ce928fc84..3c9de7fc77 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12654,28 +12654,26 @@ be used with @code{cl-yacc}.")
(sbcl-package->ecl-package sbcl-cl-lex))
(define-public sbcl-cl-colors2
- (let ((commit "7a1410765e5186625df19a875cebba685e9e51bd")
- (revision "4"))
- (package
- (name "sbcl-cl-colors2")
- (version (git-version "0.5.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/cage/cl-colors2.git")
- (commit commit)))
- (file-name (git-file-name "cl-colors2" version))
- (sha256
- (base32 "1xk3wshp21v193wbj1gs0czxaci00wwm957vmqi2dvlv0wgb2hfr"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- (list sbcl-clunit2))
- (inputs
- (list sbcl-alexandria sbcl-cl-ppcre))
- (synopsis "Color library for Common Lisp")
- (description
- "This is a very simple color library for Common Lisp, providing:
+ (package
+ (name "sbcl-cl-colors2")
+ (version "0.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/cage/cl-colors2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-colors2" version))
+ (sha256
+ (base32 "0vnvlq9xixs04768q7hapsi16cjp3ych6mypvs6chihd5dal4cnd"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-clunit2))
+ (inputs
+ (list sbcl-alexandria sbcl-cl-ppcre sbcl-parse-number))
+ (synopsis "Color library for Common Lisp")
+ (description
+ "This is a very simple color library for Common Lisp, providing:
@itemize
@item Types for representing colors in HSV, HSL, and RGB spaces.
@@ -12683,8 +12681,8 @@ be used with @code{cl-yacc}.")
@item Function printing colors to HEX, RGB, RGBA, and HSL.
@item Predefined colors from X11, SVG, and GDK.
@end itemize\n")
- (home-page "https://codeberg.org/cage/cl-colors2")
- (license license:boost1.0))))
+ (home-page "https://codeberg.org/cage/cl-colors2")
+ (license license:boost1.0)))
(define-public cl-colors2
(sbcl-package->cl-source-package sbcl-cl-colors2))