summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-04-17 23:32:52 -0700
committer宋文武 <iyzsong@member.fsf.org>2024-04-18 17:47:47 +0800
commitee9cf4f00bcb8966fa125787e8534580b270bb99 (patch)
treed28d2d3dd34fbc8011dcc9341cc6b31e89f91853
parente9481f6ce5a9c20f652e5718d472b3ec7b93bddb (diff)
gnu: putty: Update to 0.81 [security fix].
Fixes CVE-2024-31497. * gnu/packages/networking.scm (putty): Update to 0.81. Change-Id: I4c6ad42936c985c10b6a2e4b72f746c53ef0e437 Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/networking.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 0f35bca9f3..9d657bc69d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4813,7 +4813,7 @@ Further information on the usage could be found on the Wikibooks page
(define-public putty
(package
(name "putty")
- (version "0.79")
+ (version "0.81")
(source
(origin
(method url-fetch)
@@ -4822,7 +4822,7 @@ Further information on the usage could be found on the Wikibooks page
(string-append "http://www.putty.be/" version
"/putty-" version ".tar.gz")))
(sha256
- (base32 "1n7h1vprayfgjr21ccsv77g71k8dk10n69y99azqx4xvdxkci322"))))
+ (base32 "1zirfs2zh1jj2i7jcdkyvnq6pliyg8fjipx38pir8d259ylh12yb"))))
(build-system cmake-build-system)
(arguments
`(#:phases