summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 20:45:56 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:33 +0000
commiteee292979a03f3f4fd8623bf254ad9988fd7900f (patch)
tree93c9504598915d3d3adecad1d0c6e53c02fcf84a
parentde55f2146056d21061c7c9a541532b0280c4c01b (diff)
gnu: Add go-github-com-bmatcuk-doublestar-v2.
* gnu/packages/golang.scm (go-github-com-bmatcuk-doublestar-v2): New variable. Change-Id: I56d5588a1741a8e6c86320ec07bc86805f34fc91
-rw-r--r--gnu/packages/golang.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e95cd235da..e8abaffb56 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7539,6 +7539,27 @@ the library more lightweight.")
matching and globbing with support for \"doublestar\" patterns.")
(license license:expat)))
+;; For chezmoi-1.8.10
+(define-public go-github-com-bmatcuk-doublestar-v2
+ (package
+ (inherit go-github-com-bmatcuk-doublestar)
+ (name "go-github-com-bmatcuk-doublestar-v2")
+ (version "2.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bmatcuk/doublestar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09ma8a9rhs8dg527vjhdf3lsb6lajaq193m6ksssm2k3qajhpi94"))))
+ (arguments
+ (list
+ #:tests? #f ; tests have more broken parts
+ #:unpack-path "github.com/bmatcuk/doublestar/v2"
+ #:import-path "github.com/bmatcuk/doublestar/v2"))))
+
(define-public go-github-com-dlclark-regexp2
(package
(name "go-github-com-dlclark-regexp2")