summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-02 13:51:18 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-09-04 14:53:35 +0200
commitef9ad66f35617d384ac79c08cbe7125f79c7bc3f (patch)
treef419ed7a5719ef0901a32e4528363ba021e73eb5
parentab12354c0a37fb2a232935f8c5ce388d040241e2 (diff)
gnu: python-discogs-client: Update to 2.3.12.
* gnu/packages/music.scm (python-discogs-client)[version]: Update to 2.3.12. [source]: Switch to fork. [home-page]: Ditto. [synopsis]: Remove “official”. [description]: Mention we’re using a fork. [native-inputs]: Remove. [propagated-inputs]: Add python-dateutil.
-rw-r--r--gnu/packages/music.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 82c9242cd3..33abab63a9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4695,26 +4695,26 @@ provide a very simple interface for editing and playing MIDI loops.")
(define-public python-discogs-client
(package
(name "python-discogs-client")
- (version "2.2.1")
+ (version "2.3.12")
(source (origin
(method url-fetch)
- (uri (pypi-uri "discogs-client" version))
+ (uri (pypi-uri "python3-discogs-client" version))
(sha256
(base32
- "053ld2psh0yj3z0kg6z5bn4y3cr562m727494n0ayhgzbkjbacly"))))
+ "1zmib0i9jicv9fyphgkcrk418qmpv3l4p38ibl31sh237ki5xqw9"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-oauthlib" ,python-oauthlib)
+ `(("python-dateutil" ,python-dateutil)
+ ("python-oauthlib" ,python-oauthlib)
("python-requests" ,python-requests)))
- (native-inputs
- `(("python-six" ,python-six)))
- (home-page "https://github.com/discogs/discogs_client")
- (synopsis "Official Python client for the Discogs API")
- (description "This is the official Discogs API client for Python. It enables
-you to query the Discogs database for information on artists, releases, labels,
-users, Marketplace listings, and more. It also supports OAuth 1.0a
-authorization, which allows you to change user data such as profile information,
-collections and wantlists, inventory, and orders.")
+ (home-page "https://github.com/joalla/discogs_client")
+ (synopsis "Python client for the Discogs API")
+ (description "This is the continuation of the official Discogs API
+client for Python. It enables you to query the Discogs database for
+information on artists, releases, labels, users, Marketplace listings,
+and more. It also supports OAuth 1.0a authorization, which allows you to
+change user data such as profile information, collections and wantlists,
+inventory, and orders.")
(license license:bsd-2)))
(define-public python2-discogs-client