summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-07-30 21:08:49 -0400
committerLudovic Courtès <ludo@gnu.org>2022-08-05 15:28:04 +0200
commitf6f7bb51c9309e3748f04cfd7ba26cb22c101d9d (patch)
tree9935e1cc9b3704fe94827ff2c66e6dae98386532
parentf7fed0d994439a8a187c8bd0f3814fd82c49f492 (diff)
gnu: Add texlive-sourceserifpro.
* gnu/packages/tex.scm (texlive-sourceserifpro): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7afb76a763..d775c43a11 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11467,3 +11467,26 @@ algebra, using Dirac notation.")
Adobe in both Adobe Type 1 and OpenType formats, plus macros supporting the
use of the fonts in LaTeX (Type 1) and XeLaTeX/LuaLaTeX (OTF).")
(license (list license:lppl1.3+ license:silofl1.1))))
+
+(define-public texlive-sourceserifpro
+ (package
+ (inherit (simple-texlive-package
+ "texlive-sourceserifpro"
+ '("/doc/latex/sourceserifpro/"
+ "/fonts/enc/dvips/sourceserifpro/"
+ "/fonts/map/dvips/sourceserifpro/"
+ "/fonts/opentype/adobe/sourceserifpro/"
+ ;; ^ see comment on texlive-sourcesanspro
+ "/fonts/tfm/adobe/sourceserifpro/"
+ "/fonts/type1/adobe/sourceserifpro/"
+ "/fonts/vf/adobe/sourceserifpro/"
+ "/tex/latex/sourceserifpro/")
+ (base32
+ "18xxncg8ybv86r46zq5mvgkrfnvlhx93n55fy8nkk8vdmminrh8w")
+ #:trivial? #t))
+ (home-page "https://ctan.org/pkg/sourceserifpro")
+ (synopsis "Use Source Serif Pro with TeX(-alike) systems")
+ (description "This package provides the Source Serif Pro font family from
+Adobe in both Adobe Type 1 and OpenType formats, plus macros supporting the
+use of the fonts in LaTeX (Type 1) and XeLaTeX/LuaLaTeX (OTF).")
+ (license (list license:lppl1.3+ license:silofl1.1))))