summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-20 15:50:48 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-24 22:24:38 +0000
commitf74a8e8ac0a60a41303ba9253a06b466bf50178b (patch)
treefa5594e738c63d16c68778b0fa08b3fc97420b02
parent6431cf121db29b5b9d7334f573b3ea4440289acc (diff)
gnu: stackistry: Use G-Expressions.
* gnu/packages/astronomy.scm (stackistry): Update package style by using G-Expressions. Apply indention. [arguments]<#:tests?>: Use it instead of deleting check phase. <#:phases>: Remove trailing #f from each lambda. Change-Id: I30f3906719713f0d47dc2049564bc2691ba3cd5d
-rw-r--r--gnu/packages/astronomy.scm79
1 files changed, 39 insertions, 40 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 40fb9e2601..9ce805f3ef 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1227,52 +1227,51 @@ astronomical fields. SkyMaker is part of the
(base32 "0rz29v33n0x0k40hv3v79ym5ylch1v0pbph4i21809gz2al5p7dq"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list
- (string-append
- "SKRY_INCLUDE_PATH=" (assoc-ref %build-inputs "libskry") "/include")
- (string-append
- "SKRY_LIB_PATH=-L" (assoc-ref %build-inputs "libskry") "/lib")
- (string-append
- "LIBAV_INCLUDE_PATH=" (assoc-ref %build-inputs "ffmpeg") "/include"))
- #:phases
- (modify-phases %standard-phases
- ;; no configure and tests are provided
- (delete 'configure)
- (delete 'check)
- (add-after 'unpack 'fix-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "src/main.cpp"
- (("\"\\.\\.\", \"lang\"")
- "\"../share/stackistry\", \"lang\""))
- (substitute* "src/utils.cpp"
- (("\"\\.\\.\", \"icons\"")
- "\"../share/stackistry\", \"icons\""))
- #t))
- (replace 'install
- ;; The Makefile lacks an ‘install’ target.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (icons (string-append out "/share/stackistry/icons"))
- (lang (string-append out "/share/stackistry/lang")))
- (copy-recursively "bin" bin)
- (copy-recursively "icons" icons)
- (copy-recursively "lang" lang))
- #t)))))
+ (list
+ #:tests? #f ; No test target
+ #:make-flags
+ #~(list
+ (string-append
+ "SKRY_INCLUDE_PATH=" #$(this-package-input "libskry") "/include")
+ (string-append
+ "SKRY_LIB_PATH=-L" #$(this-package-input "libskry") "/lib")
+ (string-append
+ "LIBAV_INCLUDE_PATH=" #$(this-package-input "ffmpeg") "/include"))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; no configure and tests are provided
+ (delete 'configure)
+ (add-after 'unpack 'fix-paths
+ (lambda _
+ (substitute* "src/main.cpp"
+ (("\"\\.\\.\", \"lang\"")
+ "\"../share/stackistry\", \"lang\""))
+ (substitute* "src/utils.cpp"
+ (("\"\\.\\.\", \"icons\"")
+ "\"../share/stackistry\", \"icons\""))))
+ (replace 'install
+ ;; The Makefile lacks an ‘install’ target.
+ (lambda _
+ (let* ((out #$output)
+ (bin (string-append out "/bin"))
+ (icons (string-append out "/share/stackistry/icons"))
+ (lang (string-append out "/share/stackistry/lang")))
+ (copy-recursively "bin" bin)
+ (copy-recursively "icons" icons)
+ (copy-recursively "lang" lang)))))))
(native-inputs
(list pkg-config))
- (inputs
- (list gtkmm-3 libskry ffmpeg-4))
- (home-page "https://github.com/GreatAttractor/stackistry")
- (synopsis "Astronomical lucky imaging/image stacking tool")
- (description
- "Stackistry implements the lucky imaging principle of astronomical
+ (inputs
+ (list gtkmm-3 libskry ffmpeg-4))
+ (home-page "https://github.com/GreatAttractor/stackistry")
+ (synopsis "Astronomical lucky imaging/image stacking tool")
+ (description
+ "Stackistry implements the lucky imaging principle of astronomical
imaging: creating a high-quality still image out of a series of many (possibly
thousands) low quality ones (blurred, deformed, noisy). The resulting image
stack typically requires post-processing, including sharpening (e.g. via
deconvolution). Such post-processing is not performed by Stackistry.")
- (license license:gpl3+)))
+ (license license:gpl3+)))
(define-public stellarium
(package