summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-05-14 17:26:46 +0200
committerLudovic Courtès <ludo@gnu.org>2024-05-14 17:26:46 +0200
commitf98e90c2681d15610a6502b07c92c3871f2b56db (patch)
tree0f74a76fd5ae5c33be3a1c0046e3e4f073639d9c
parent2fd81ef8296b8a716d27780527a96b3fa5492926 (diff)
gnu: Avoid cycle involving (gnu packages pkg-config).
Fixes a regression introduced in 7a26aee61bbbd8e37745ce13433545333eac4505 whereby (gnu packages pkg-config) would be caught in a cycle, leading to miscompilation of package modules, in turn leading to failure to compute the Guix derivation with exceptions like: 1. &package-input-error: package: #<package libgc@8.2.4 7fee96c4dc60> input: ("_" #<syntax-transformer pkg-config>) * gnu/packages/pkg-config.scm: Autoload (gnu packages check). Change-Id: I624e701a0c411b6f3d9ad5e10dca6ad7cf552be4
-rw-r--r--gnu/packages/pkg-config.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/pkg-config.scm b/gnu/packages/pkg-config.scm
index d1c6c644ac..d5655bd893 100644
--- a/gnu/packages/pkg-config.scm
+++ b/gnu/packages/pkg-config.scm
@@ -29,7 +29,13 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (gnu packages bash)
- #:use-module (gnu packages check)
+
+ ;; Note: Because this module defines the 'pkg-config' macro, it cannot be
+ ;; caught in a cycle with other package modules or the macro wouldn't be
+ ;; visible at the time those other modules are compiled. To fulfill that
+ ;; constraint, load (gnu packages check) lazily.
+ #:autoload (gnu packages check) (atf kyua)
+
#:use-module (guix memoization)
#:export (pkg-config))