summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:51:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:30 +0200
commitfcc06aec35a081ee32e80a777b6f3bc9f90f4cc7 (patch)
tree67a99d3cf2f5d221a4ed118e77665013b9a3236c
parenteb1d39e74fa80d4f2f7a2478d978fdf468edb277 (diff)
gnu: Add texlive-getoptk.
* gnu/packages/tex.scm (texlive-getoptk): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 71dfa0aed3..8a19c6d141 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2741,6 +2741,25 @@ EPS files and @command{psfrag} substitution definition files, and produces PDF
and EPS files with the substitutions included.")
(license license:gpl3+)))
+(define-public texlive-getoptk
+ (package
+ (name "texlive-getoptk")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/plain/getoptk/" "tex/plain/getoptk/")
+ (base32
+ "19ndqi977wk6f9ikcvbllcbxmmfzdanjfznzx6pkq41caf4mj91y")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/getoptk")
+ (synopsis "Define macros with sophisticated options")
+ (description
+ "The package provides a means of defining macros whose options are taken
+from a dictionary, which includes options which themselves have arguments.
+The package was designed for use with Plain TeX.")
+ (license license:cecill-b)))
+
(define-public texlive-tex
(package
(name "texlive-tex")