summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-01 14:35:16 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2024-02-12 10:39:12 +0100
commit4a92cd5c6898d95636de347d4b1859a8605de90d (patch)
tree48789a03de5a9aa5dabccfe4e393f2f846811a8f
parentfaa85198e30b15890143ee8160c81530651e61cb (diff)
gnu: gcc: Simplify application of Hurd-specific pthread patch.
* gnu/packages/gcc.scm (gcc-11): Apply gcc-11-libstdc++-hurd-libpthread.patch unconditionally. (gcc-12): Also apply gcc-11-libstdc++-hurd-libpthread.patch. Change-Id: I80e2b2adb5636e1bff4536c5a0a348955454e81d
-rw-r--r--gnu/packages/gcc.scm18
1 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index a97693d5e8..3162f474b6 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -731,21 +731,10 @@ It also includes runtime support libraries for these languages.")
(base32
"1ncd7akww0hl5kkmw1dj3qgqp3phdrr5dfnm7jia9s07n0ib4b9z"))
(patches (search-patches "gcc-9-strmov-store-file-names.patch"
- "gcc-5.0-libvtv-runpath.patch"))
+ "gcc-5.0-libvtv-runpath.patch"
+ "gcc-11-libstdc++-hurd-libpthread.patch"))
(modules '((guix build utils)))
(snippet gcc-canadian-cross-objdump-snippet)))
- (arguments
- (substitute-keyword-arguments (package-arguments gcc-8)
- ((#:phases phases #~%standard-phases)
- (if (target-hurd?)
- #~(modify-phases #$phases
- (add-after 'unpack 'patch-hurd-libpthread
- (lambda _
- (define patch
- #$(local-file
- (search-patch "gcc-11-libstdc++-hurd-libpthread.patch")))
- (invoke "patch" "--force" "-p1" "-i" patch))))
- phases))))
(properties
`((compiler-cpu-architectures
("aarch64" ,@%gcc-11-aarch64-micro-architectures)
@@ -765,7 +754,8 @@ It also includes runtime support libraries for these languages.")
(base32
"0fwcvbgpmjdfj5drfs8k6bkqsmxmz8pv4cmmjcd451p7k57mv6ll"))
(patches (search-patches "gcc-12-strmov-store-file-names.patch"
- "gcc-5.0-libvtv-runpath.patch"))
+ "gcc-5.0-libvtv-runpath.patch"
+ "gcc-11-libstdc++-hurd-libpthread.patch"))
(modules '((guix build utils)))
(snippet gcc-canadian-cross-objdump-snippet)))
(properties