summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-13 22:52:32 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:09:33 +0100
commit53790fdede82867776a982eeec6d36679ceea12b (patch)
tree27dce814a687da128486ca9fa6998dad1c8c85c7
parentff74f98818415da944e93c1ebc09dc069e983466 (diff)
gnu: python-natsort: Add en_US.UTF-8 locale for tests.
* gnu/packages/python-xyz.scm (python-natsort): Add en_US.UTF-8 locale for the package's tests. Change-Id: I5947b6550b9bc71d403685756ead4f1c77c99012
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a7360369fe..de98906619 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21826,7 +21826,10 @@ implementation of your Python package and its public API surface.")
(when tests?
(invoke "pytest" "-v")))))))
(native-inputs
- (list python-hypothesis python-pytest-cov python-pytest-mock
+ (list glibc-utf8-locales ;; Tests want en_US.UTF-8
+ python-hypothesis
+ python-pytest-cov
+ python-pytest-mock
python-pytest))
(propagated-inputs ; TODO: Add python-fastnumbers.
(list python-pyicu))