summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-17 11:52:27 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2024-02-12 10:39:09 +0100
commit68ea63a3306c21d3de77d6ff65aa8b8576731009 (patch)
tree56677cd06a20dfc193371934b5d9461068699c8b
parentbee252bce2cc28c4fd0c81546c002fbf57304aac (diff)
gnu: lvm2-static: Properly handle eudev dependency in pkg-config.
* gnu/packages/linux.scm (lvm2-static): Add linking flags for the static eudev output. Change-Id: Ic43be600f0569a8ffa69544cbf661f05d82e2084
-rw-r--r--gnu/packages/linux.scm39
1 files changed, 24 insertions, 15 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c7da4957bf..ba81cbad3e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4596,8 +4596,8 @@ mapper. Kernel components are part of Linux-libre.")
(inherit lvm2)
(name "lvm2-static")
- ;; Propagate udev because libdevmapper.a depends on libudev.
- (propagated-inputs `(("udev:static" ,eudev "static")))
+ (inputs `(,@(package-inputs lvm2)
+ ("udev:static" ,eudev "static")))
(arguments
(substitute-keyword-arguments (package-arguments lvm2)
@@ -4611,19 +4611,28 @@ mapper. Kernel components are part of Linux-libre.")
;; it until the situation improves.
(delete "--enable-dmeventd" ,flags)))
((#:phases phases)
- `(modify-phases ,phases
- (add-before 'configure 'adjust-Makefile
- (lambda _
- ;; These fixes are related to the upstream libdm->device_mapper
- ;; migration and will hopefully be fixed upstream in due time.
- (substitute* "tools/Makefile.in"
- ;; This variable is empty in a static configuration and causes
- ;; an erroneous GCC command line.
- (("-L\\$\\(interfacebuilddir\\)") "")
- ;; Remove obsolete reference to libdevmapper.a.
- (("-ldevmapper") ""))
- #t))))))
- (synopsis "Logical volume management for Linux (statically linked)")))
+ #~(modify-phases #$phases
+ (add-before 'configure 'adjust-Makefile
+ (lambda _
+ ;; These fixes are related to the upstream libdm->device_mapper
+ ;; migration and will hopefully be fixed upstream in due time.
+ (substitute* "tools/Makefile.in"
+ ;; This variable is empty in a static configuration and causes
+ ;; an erroneous GCC command line.
+ (("-L\\$\\(interfacebuilddir\\)") "")
+ ;; Remove obsolete reference to libdevmapper.a.
+ (("-ldevmapper") ""))
+ #t))
+ (add-after 'install 'adjust-pkgconfig
+ ;; The static eudev is missing its pkg config file, and I am not
+ ;; rebuilding it at this point.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (string-append #$output "/lib/pkgconfig/devmapper.pc")
+ (("Requires.private: .*") "")
+ (("Libs.private:")
+ (format #f "Libs.private: -L~a -ludev"
+ (dirname (search-input-file inputs "lib/libudev.a")))))))))))
+ (synopsis "Logical volume management for Linux (statically linked)")))
(define-public thin-provisioning-tools
(package