summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-02 19:03:55 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:09:28 +0100
commit7f245a7843a162ea76e560161d63283ffa50b2c6 (patch)
tree2e758ff84a1aded2c63b63e8c14659feaf901e22
parente2030ed3bd9b15e5002f14e97d8008f1d077ea1d (diff)
gnu: apr: Add libxcrypt dependency.
* gnu/packages/apr.scm (apr): Add libxcrypt dependency. Change-Id: Ib43ea0e3933e0df27654638150f21b8f8f504512
-rw-r--r--gnu/packages/apr.scm30
1 files changed, 20 insertions, 10 deletions
diff --git a/gnu/packages/apr.scm b/gnu/packages/apr.scm
index 3bd4d1ecce..b3bb1f80e3 100644
--- a/gnu/packages/apr.scm
+++ b/gnu/packages/apr.scm
@@ -26,6 +26,7 @@
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages crypto)
#:use-module (gnu packages perl)
#:use-module (gnu packages xml)
#:use-module (gnu packages autotools))
@@ -51,16 +52,25 @@
;; Thus, build sequentially.
`(#:parallel-build? #f
#:parallel-tests? #f
- ,@(if (target-ppc32?)
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-sources
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (invoke "patch" "-p1" "--force" "--input"
- (assoc-ref (or native-inputs inputs)
- "atomics-patch"))))))
- '())))
- (inputs (list perl libltdl))
+ #:phases
+ (modify-phases %standard-phases
+ ,@(if (target-ppc32?)
+ `((add-after 'unpack 'patch-sources
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (invoke "patch" "-p1" "--force" "--input"
+ (assoc-ref (or native-inputs inputs)
+ "atomics-patch")))))
+ '())
+ (add-after 'install 'patch-libxcrypt-reference
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (define out (assoc-ref outputs "out"))
+ (define libxcrypt
+ (dirname (search-input-file inputs "/lib/libcrypt.so.1")))
+ (substitute* (list (string-append out "/bin/apr-1-config")
+ (string-append out "/lib/pkgconfig/apr-1.pc"))
+ (("-lcrypt")
+ (string-append "-L" libxcrypt " -lcrypt"))))))))
+ (inputs (list perl libltdl libxcrypt))
(native-inputs
`(,@(if (target-ppc32?)
`(("atomics-patch"