summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-16 18:38:18 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2024-02-12 10:39:08 +0100
commit96231b73ece15c0fada5608a2e045c17142ce334 (patch)
tree56bc662beea56969f44173e91213c89cf4af481c
parentdec5533d5e397d8ed460cd720a938fab1eb07778 (diff)
gnu: volume-key: Add required transitive dependencies.
* gnu/packages/disk.scm (volume-key): Add transitive dependencies for libdevmapper and libcryptsetup. Change-Id: Iaced5bedd2f6ec8e67118b2ee4d01f14704a3694
-rw-r--r--gnu/packages/disk.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 4582ad3555..6cc191ff25 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1036,12 +1036,13 @@ and its highly optimized now for efficient performance.")
(native-inputs
(list pkg-config swig python-3)) ; used to generate the Python bindings
(inputs
- `(("cryptsetup" ,cryptsetup)
- ("nss" ,nss)
- ("libblkid" ,util-linux "lib")
- ("lvm2" ,lvm2) ; for "-ldevmapper"
- ("glib" ,glib)
- ("gpgme" ,gpgme)))
+ (append
+ (cons cryptsetup (libcryptsetup-propagated-inputs))
+ (cons lvm2 (libdevmapper-propagated-inputs))
+ (list nss
+ (list util-linux "lib")
+ glib
+ gpgme)))
(arguments
`(#:tests? #f ; not sure how tests are supposed to pass, even when run manually
#:phases