summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:07:32 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:09:36 +0100
commitbfbe26989b85eda59f971472a8acbdf8da4b6afd (patch)
tree462730f08a453f3aef607c1927fbf78457e63d9e
parentd1fe64677388d833fd247bd4bbf76ee0ec529ba7 (diff)
gnu: tevent: Remove reference to crypt.
* gnu/packages/samba.scm (tevent): Remove reference to crypt header. Change-Id: Ic99712c9374dee1fd5b65c29327fe39aa10eed35
-rw-r--r--gnu/packages/samba.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index bf92b210c3..2d1ea5959d 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -397,6 +397,14 @@ destructors. It is the core memory allocator used in Samba.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-crypt-reference
+ ;; The following is needed because Python.h propagates
+ ;; HAVE_CRYPT_H, which is then seen from lib/replace/ but talloc
+ ;; doesn't need it at all.
+ (lambda _
+ (substitute* "lib/replace/replace.h"
+ (("#include <crypt.h>")
+ ""))))
(replace 'configure
;; tevent uses a custom configuration script that runs waf.
(lambda* (#:key outputs #:allow-other-keys)