summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:07:43 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:09:37 +0100
commitc0aafa2206c7bfad8660703197745ddf504c2f24 (patch)
tree409c4f276625fa9b4e56cbcb604ad4704569a716
parentbfbe26989b85eda59f971472a8acbdf8da4b6afd (diff)
gnu: ldb: Remove reference to crypt.
* gnu/packages/samba.scm (ldb): Remove reference to crypt header. Change-Id: Idcf43ff9b140d5c7e601d853564833525396e565
-rw-r--r--gnu/packages/samba.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 2d1ea5959d..ae3966664f 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -451,6 +451,14 @@ many event types, including timers, signals, and the classic file descriptor eve
#:tests? (assoc-ref %build-inputs "lmdb")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-crypt-reference
+ ;; The following is needed because Python.h propagates
+ ;; HAVE_CRYPT_H, which is then seen from lib/replace/ but talloc
+ ;; doesn't need it at all.
+ (lambda _
+ (substitute* "lib/replace/replace.h"
+ (("#include <crypt.h>")
+ ""))))
(replace 'configure
;; ldb use a custom configuration script that runs waf.
(lambda* (#:key outputs #:allow-other-keys)