summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:07:09 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:09:36 +0100
commitd1fe64677388d833fd247bd4bbf76ee0ec529ba7 (patch)
tree5322c254e53a42986db04be3e71d18fe7eae3467
parentd6c584575f99d24df9158e874e9b7ed7f008cc0e (diff)
gnu: talloc: Remove reference to crypt.
* gnu/packages/samba.scm (talloc): Remove reference to crypt header. Change-Id: I370069acdd7992f2660aae0b1840ea7756befe13
-rw-r--r--gnu/packages/samba.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index ce707a8912..bf92b210c3 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -322,6 +322,14 @@ Desktops into Active Directory environments using the winbind daemon.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-crypt-reference
+ ;; The following is needed because Python.h propagates
+ ;; HAVE_CRYPT_H, which is then seen from lib/replace/ but talloc
+ ;; doesn't need it at all.
+ (lambda _
+ (substitute* "lib/replace/replace.h"
+ (("#include <crypt.h>")
+ ""))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
;; talloc uses a custom configuration script that runs a Python