summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:03:22 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:09:33 +0100
commite95eb0e135ca418905afa6fdb492401c0c421f62 (patch)
tree334f18a5992d384b508bb9755c948a0f28df0374
parent53790fdede82867776a982eeec6d36679ceea12b (diff)
gnu: cryptsetup: G-Expify static-library.
* gnu/packages/cryptsetup.scm (static-library): G-Expify it. Change-Id: I3123cab24b08acdb5a28e0052e9a9663d00fd564
-rw-r--r--gnu/packages/cryptsetup.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index 8ff649bccc..6765fed726 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -107,9 +107,9 @@ files). This assumes LIBRARY uses Libtool."
(name (string-append (package-name library) "-static"))
(arguments
(substitute-keyword-arguments (package-arguments library)
- ((#:configure-flags flags ''())
- `(append '("--disable-shared" "--enable-static")
- ,flags))))))
+ ((#:configure-flags flags #~'())
+ #~(append '("--disable-shared" "--enable-static")
+ #$flags))))))
(define-public cryptsetup-static
;; Stripped-down statically-linked 'cryptsetup' command for use in initrds.