summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-03-25 16:26:48 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-03-25 16:26:48 +0100
commit01d7ce85c89bc25876538f191be6bed4226d1593 (patch)
treecc2b2832692e0affbcbe7ed01934f81b31cabfe3
parente2f408030dfc442797054640c6ff28ad1596b4c9 (diff)
gnu: nuspell: Update to 5.1.4.
* gnu/packages/enchant.scm (nuspell): Update to 5.1.4. [native-inputs]: Use CATCH2-3. Remove comment about RONN, which is no longer used. Change-Id: I62fa0568dacde29bef5065b2ee23c060373727cf
-rw-r--r--gnu/packages/enchant.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index 015af0d096..f836a734bb 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -43,31 +43,25 @@
(define-public nuspell
(package
(name "nuspell")
- (version "3.1.2")
+ (version "5.1.4")
(source
(origin
(method git-fetch)
(uri
(git-reference
(url "https://github.com/nuspell/nuspell")
- (commit
- (string-append "v" version))))
- (file-name
- (git-file-name name version))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0wbb6dwmzlsyy224y0liis0azgzwbjdvcyzc31pw1aw6vbp36na6"))))
+ (base32 "05j1hmczy6v9dyxp77vxhgyl7y5hff3v45vlp86gyh7m9lgqpmra"))))
(build-system cmake-build-system)
(native-inputs
- (list catch2
+ (list catch2-3
git-minimal
perl
- ;;FIX-ME: Building with ronn fails.
- ;;("ronn" ,ronn)
pkg-config))
- (inputs
- (list boost))
- (propagated-inputs
- (list icu4c))
+ (inputs (list boost))
+ (propagated-inputs (list icu4c))
(synopsis "Fast and safe spellchecking C++ library")
(description "Nuspell is a fast and safe spelling checker software
program. It is designed for languages with rich morphology and complex word