summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-03-25 17:26:24 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-03-25 17:26:24 +0100
commit929ddec8f4a181be653152c7436581c2adc54eee (patch)
tree5935ea18eb754c372f8898075381b74a2afe8899
parent53aa1677cfb084056f44646e4dfc27d91de82c98 (diff)
gnu: nuspell: Add search path specification for DICPATH.
* gnu/packages/enchant.scm (nuspell)[native-search-path]: Add DICPATH. This change is required to let Nuspell detect Hunspell dictionaries. Change-Id: I731752142afcae1fc2b91c01fb9dbe914d33244f
-rw-r--r--gnu/packages/enchant.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index c9351ed3c3..5efa0f2689 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -57,6 +57,9 @@
(build-system cmake-build-system)
(native-inputs (list catch2-3 pkg-config))
(propagated-inputs (list icu4c))
+ (native-search-paths (list (search-path-specification
+ (variable "DICPATH")
+ (files '("share/hunspell")))))
(synopsis "Fast and safe spellchecking C++ library")
(description "Nuspell is a fast and safe spelling checker software
program. It is designed for languages with rich morphology and complex word