summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-03-15 21:08:15 -0300
committerVinicius Monego <monego@posteo.net>2024-03-23 09:30:45 -0300
commit1e103064607ab2d6668559da1de84cded5247e10 (patch)
treed04ca21f0d8cfa63d31f3f2d6731cf2fa56000af
parent7ef2959085cf7722c401ce8efe52c7da1bab73a9 (diff)
gnu: python-scrapy: Update to 2.11.1.
* gnu/packages/python-web.scm (python-scrapy): Update to 2.11.1. [native-inputs]: Add python-pexpect. Change-Id: Ief50a55a27a2b6e3ae143d43a8b07a9011048565
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9ad081beb1..fc01fc4b83 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8478,13 +8478,13 @@ regular expressions.")
(define-public python-scrapy
(package
(name "python-scrapy")
- (version "2.11.0")
+ (version "2.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Scrapy" version))
(sha256
- (base32 "199nbc7vipdsvxmfxc0lrzbprgl3hr2xgqhvss1083iz1k7fvg9w"))))
+ (base32 "1giyyzwcybmh0yf3aq44hhmf9m4k40rva418pxljpr93fjf06fkk"))))
(build-system pyproject-build-system)
(arguments
(list #:test-flags
@@ -8520,7 +8520,8 @@ regular expressions.")
python-w3lib
python-zope-interface))
(native-inputs
- (list python-pytest
+ (list python-pexpect
+ python-pytest
python-pytest-xdist
python-pyftpdlib
python-sybil