summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-13 13:43:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-13 13:54:59 +0100
commit238e4ec73e4143f3a5a85b56ca00d395cdf60197 (patch)
tree225b46e1ffbe1d5875fe4478e8d1ba998a6864e2
parentd1146d8ecb9bd7e03d273dddb5562c0338dafdc7 (diff)
gnu: ploticus: Refresh package style.
* gnu/packages/plotutils.scm (ploticus): Apply G-expressions to refresh package style. Change-Id: Iabf465a9bd4e02c1087b117533dbbf0b4c1a3f14
-rw-r--r--gnu/packages/plotutils.scm60
1 files changed, 27 insertions, 33 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 84fb5fa7ac..d0cc1bc842 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -310,41 +310,35 @@ went to university in the 1990s, this is the library for you.")
(modules '((guix build utils)))
(snippet
;; Install binaries in the right place.
- '(begin
- (substitute* "src/Makefile"
- (("INSTALLBIN =.*$")
- (string-append "INSTALLBIN = $(out)/bin")))
- #t))))
+ #~(begin
+ (substitute* "src/Makefile"
+ (("INSTALLBIN =.*$")
+ (string-append "INSTALLBIN = $(out)/bin")))))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'configure (lambda _ (chdir "src")))
- (add-before 'install 'make-target-directories
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/bin"))
- #t)))
- (add-after 'install 'install-prefabs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dir (string-append out
- "/share/ploticus/prefabs"))
- (bin (string-append out "/bin")))
- (mkdir-p dir)
-
- ;; Install "prefabs".
- (for-each (lambda (file)
- (let ((target
- (string-append dir "/"
- (basename file))))
- (copy-file file target)))
- (find-files "../prefabs" "."))
-
- ;; Allow them to be found.
- (wrap-program (string-append bin "/pl")
- `("PLOTICUS_PREFABS" ":" = (,dir)))))))))
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure (lambda _ (chdir "src")))
+ (add-before 'install 'make-target-directories
+ (lambda _
+ (mkdir-p (string-append #$output "/bin"))))
+ (add-after 'install 'install-prefabs
+ (lambda _
+ (let* ((out #$output)
+ (dir (string-append out "/share/ploticus/prefabs"))
+ (bin (string-append out "/bin")))
+ (mkdir-p dir)
+ ;; Install "prefabs".
+ (for-each
+ (lambda (file)
+ (let ((target (string-append dir "/" (basename file))))
+ (copy-file file target)))
+ (find-files "../prefabs" "."))
+ ;; Allow them to be found.
+ (wrap-program (string-append bin "/pl")
+ `("PLOTICUS_PREFABS" ":" = (,dir)))))))))
(inputs
(list libpng libx11 zlib))
(home-page "https://ploticus.sourceforge.net/")