summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 21:24:18 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 21:57:33 +0000
commit4172a5ae9bc1a1c22a7c878c70e5c4027a721483 (patch)
treed22ccb44b9c3de7691c8e42a793fd196ac41dddb
parent79394fd0a9a86c33337743b717c6fd7e0ebb6c23 (diff)
gnu: cl-generic-cl: Refresh package style.
* gnu/packages/lisp-xyz.scm (sbcl-generic-cl): [arguments]: Move above inputs. [inputs]: Remove labels. Change-Id: I366230776df1686b16e920088c9e1ce99c49d469
-rw-r--r--gnu/packages/lisp-xyz.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 853fdf2ab7..7ba339cb93 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17131,21 +17131,21 @@ Macros and symbol-macros are fully expanded and all special forms, except
(base32
"1c40vqb49g0adfv17jxgk0ds1n6a2dph30cibq01sicmqdgrrbi8"))))
(build-system asdf-build-system/sbcl)
- (inputs
- `(("agutil" ,sbcl-agutil)
- ("alexandria" ,sbcl-alexandria)
- ("anaphora" ,sbcl-anaphora)
- ("arrows" ,sbcl-arrows)
- ("cl-custom-hash-table" ,sbcl-custom-hash-table)
- ("cl-form-types" ,sbcl-cl-form-types)
- ("static-dispatch" ,sbcl-static-dispatch)
- ("trivia" ,sbcl-trivia)))
- (native-inputs
- (list sbcl-prove))
(arguments
;; Tests fail because SBCL head size is not high enough.
;; https://github.com/alex-gutev/generic-cl/issues/6
`(#:tests? #f))
+ (inputs
+ (list sbcl-agutil
+ sbcl-alexandria
+ sbcl-anaphora
+ sbcl-arrows
+ sbcl-cl-form-types
+ sbcl-custom-hash-table
+ sbcl-static-dispatch
+ sbcl-trivia))
+ (native-inputs
+ (list sbcl-prove))
(home-page "https://alex-gutev.github.io/generic-cl/")
(synopsis "Generic function interface to standard Common Lisp functions")
(description "@code{generic-cl} provides a generic function wrapper over