summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:08:18 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:44 +0100
commit49d917e675cd83764ed011793fcefe544b637d83 (patch)
tree7de04427ef4d7acd9a9c4f88bbf1ac2e82015d1b
parent2d10f8eb0bc1559a44fd6fbeb705c5bfc30e5508 (diff)
gnu: Add go-go-uber-org-fx.
* gnu/packages/golang-xyz.scm (go-go-uber-org-fx): New variable. Change-Id: Ib8410424acc31caf486f2d6cd14e736a110efa0f
-rw-r--r--gnu/packages/golang-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 1d41da74ef..63529e631d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3263,6 +3263,39 @@ CPU quota.")
object dependencies graph during the process startup.")
(license license:expat)))
+(define-public go-go-uber-org-fx
+ (package
+ (name "go-go-uber-org-fx")
+ (version "1.21.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://pkg.go.dev/go.uber.org/fx")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16pbqmkij02zw6xa4660k905y0r0rc50vyqhg41i2411r68jrdnn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.20
+ #:import-path "go.uber.org/fx"))
+ (native-inputs
+ (list go-github-com-stretchr-testify-next))
+ (propagated-inputs
+ (list go-go-uber-org-dig
+ go-go-uber-org-goleak
+ go-go-uber-org-multierr
+ go-go-uber-org-zap
+ go-golang-org-x-sys))
+ (home-page "https://go.uber.org/fx")
+ (synopsis "Dependency injection based application framework for Golang")
+ (description
+ "Package @code{fx} is a framework that makes it easy to build
+applications out of reusable, composable modules.")
+ (license license:expat)))
+
(define-public go-go-uber-org-multierr
(package
(name "go-go-uber-org-multierr")