summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2024-04-11 12:40:19 -0700
committerChristopher Baines <mail@cbaines.net>2024-04-15 10:08:32 +0100
commit4dec6e9fb74a688e0297b127773b88a699531785 (patch)
tree3d0fab7e1c913b5819b1780e1bd7723554735503
parentd95ed91f386032b8de46785c407ef5b64794bd89 (diff)
gnu: diffoscope: Increase test verbosity.
* gnu/packages/diffoscope.scm (diffoscope)[phases]: Replace 'check. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/diffoscope.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 3db52e5008..8106a6d258 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -139,6 +139,11 @@
(lambda _
;; This requires /sbin to be in $PATH.
(delete-file "tests/test_tools.py")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Increase verbosity of tests and provide a summary
+ (invoke "pytest" "-vv" "-r" "sxX"))))
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))