summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-14 14:43:11 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-14 14:52:23 +0100
commit6b3c90f638292f9604a221ac6dbf22234f6e4c4b (patch)
treeddb799e66734c78172636ae9f921cf1540d9e3d1
parentec8eef5e7e4b6c871bd8a9938ae64f6dd1277a3c (diff)
gnu: go-github-com-francoispqt-gojay: Run tests only on x86-64.
Address the build issue on i686-linux as seen in CI <https://ci.guix.gnu.org/build/3395366/details>. * gnu/packages/golang-web.scm (go-github-com-francoispqt-gojay): [arguments]: Swap to list style. <#:tests?>: Only run on x86-64. [home-page]: Move above synopsis. [description]: Fix indentation. Change-Id: I93a0970933de0b32729cf9a620b10e69e8e244eb
-rw-r--r--gnu/packages/golang-web.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e1b366a118..91f075ca2e 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -553,6 +553,8 @@ metrics (i.e. response time, bytes written, and http status code) from your
application's http.Handlers.")
(license license:expat)))
+;; This project looks like domain or abandoned, see
+;; <https://github.com/francoispqt/gojay/issues/150>.
(define-public go-github-com-francoispqt-gojay
(package
(name "go-github-com-francoispqt-gojay")
@@ -568,14 +570,20 @@ application's http.Handlers.")
(base32 "1ix95qdyajfmxhf9y52vjrih63f181pjs4v5as8905s4d5vmkd06"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/francoispqt/gojay"))
+ (list
+ ;; XXX: Disable failing tests on non-x86-64 architecture, see
+ ;; <https://github.com/francoispqt/gojay/issues/173>.
+ #:tests? (and (not (%current-target-system))
+ (target-x86-64?))
+ #:import-path "github.com/francoispqt/gojay"))
(native-inputs
(list go-github-com-stretchr-testify))
+ (home-page "https://github.com/francoispqt/gojay")
(synopsis "JSON encoder/decoder with powerful stream API for Golang")
- (description "GoJay is a performant JSON encoder/decoder for Golang. It has
-a simple API and doesn't use reflection. It relies on small interfaces to
+ (description
+ "GoJay is a performant JSON encoder/decoder for Golang. It has a simple
+API and doesn't use reflection. It relies on small interfaces to
decode/encode structures and slices.")
- (home-page "https://github.com/francoispqt/gojay")
(license license:expat)))
;; TODO: This repository has been archived by the owner on Aug 30, 2023. It is