summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-03-17 15:10:31 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 23:50:26 +0000
commit791578befb7e129f682f38bfe903c23baa46fb91 (patch)
tree3f0e1efc6dd071b2fa121c89ee4a71651f79ed51
parent9a5b9dad0d542b94bc34d5d5cfab70bff6c29c90 (diff)
gnu: Add go-github-com-multiformats-go-varint.
* gnu/packages/golang-xyz.scm (go-github-com-multiformats-go-varint): New variable. Change-Id: Ib2f82fff0fbed00010c2aa7993134d5a855f0d7d Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 665bb5c7d7..cf0b52a043 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1366,6 +1366,30 @@ command line flags, config files, and default struct values.")
@url{https://github.com/judwhite/go-svc/raw/master/svc/svc_windows_test.go,here}.")
(license license:expat))))
+(define-public go-github-com-multiformats-go-varint
+ (package
+ (name "go-github-com-multiformats-go-varint")
+ (version "0.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-varint")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l4s0z3rc3d350zp6qximl1jjhic6l8w74wkmx244jgfzsxd93af"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mreiferson/go-options"))
+ (home-page "https://github.com/mreiferson/go-options")
+ (synopsis "Varint helpers that enforce minimal encoding")
+ (description
+ "This package provides a functionality for encoding and decoding unsigned
+varints.")
+ (license license:expat)))
+
(define-public go-github-com-nats-io-nats-go
(package
(name "go-github-com-nats-io-nats-go")