summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-04-07 17:07:30 +0530
committerChristopher Baines <mail@cbaines.net>2024-04-15 09:58:50 +0100
commit8a257582e3366b37ab7651198fc4c8912c520b37 (patch)
tree01f48d957e709c2969ff46eb5fed387f37811a6c
parent027419626f171cdccf9c4a77686840141ea502eb (diff)
gnu: signon-plugin-oauth2: Fix installing in a doubled prefix.
This commit fixes creating one more /gnu/store/ directory inside its own prefix, creating again the same prefix inside it and then installing in it. * gnu/packages/qt.scm (signon-plugin-oauth2)[arguments]: <#:make-flags>: Remove argument. <#:phases>: In configure phase, add SIGNON_PLUGINS_DIR variable. Change-Id: I10e973980228354c9943741dd480544bffca65b8 Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/qt.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 13af841455..198325c03a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -5360,7 +5360,6 @@ authentication on behalf of its clients.")
(inputs (list signond))
(arguments
(list #:tests? #f ;no tests
- #:make-flags #~(list (string-append "INSTALL_ROOT=" #$output))
#:phases
#~(modify-phases %standard-phases
(replace 'configure
@@ -5370,7 +5369,9 @@ authentication on behalf of its clients.")
""))
(invoke "qmake"
(string-append "PREFIX=" #$output)
- (string-append "LIBDIR=" #$output "/lib")))))))
+ (string-append "LIBDIR=" #$output "/lib")
+ (string-append "SIGNON_PLUGINS_DIR=" #$output
+ "/lib")))))))
(synopsis "OAuth 2 plugin for signon")
(description
"This plugin for the Accounts-SSO SignOn daemon handles the OAuth