summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Eduardo <eduarskate8@gmail.com>2024-03-31 12:33:04 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-04-15 12:01:22 +0200
commit91239079f3aa05aa515c7afc43241149ff75d33c (patch)
treedf89829db5311cac58586e9e78069666c1e7c355
parent8e3831eb126478cad50588a0f3474667981b11ec (diff)
gnu: Add sandbar.
* gnu/packages/wm.scm (sandbar): New variable. Change-Id: I93f91436420a733a3b74d9b88ed5d69a9369ee38 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/wm.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4e76e705e1..b5e9dca524 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2024 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2024 chris <chris@bumblehead.com>
+;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1384,6 +1385,41 @@ Keybinder works with GTK-based applications using the X Window System.")
(define-public keybinder-3.0
(deprecated-package "keybinder-3.0" keybinder))
+(define-public sandbar
+ (package
+ (name "sandbar")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kolunmi/sandbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0912cr2q2kg4nqdwy978kpmdcj2cjz3gnlcb28ny9z3cprxvyvxq"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)) ;no configure script
+ #:tests? #f ;no check target
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))))
+ (inputs (list fcft wayland))
+ (native-inputs (list pkg-config wayland-protocols))
+ (synopsis "DWM-like bar for the River Wayland compositor")
+ (description "Sandbar is a minimalist DWM-like bar designed for River,
+a Wayland compositor. It is triggered through commands sent via standard
+input, providing extensive customization options. This behavior allows users
+to dynamically adjust status text, visibility, and bar location, making
+Sandbar an ideal choice for those seeking a lightweight and hackable bar
+solution in their Wayland environment.")
+ ;; LICENSE LICENSE.dtao
+ (license (list license:gpl3 license:expat))
+ (home-page "https://github.com/kolunmi/sandbar")))
+
(define-public spectrwm
(package
(name "spectrwm")