summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-04-09 12:22:35 +0200
committerChristopher Baines <mail@cbaines.net>2024-04-15 10:14:06 +0100
commit94fa92cc8ebcaa7ea8a401d34fc9d5ed9bd3aa9e (patch)
treeaff7cfb8516040a4b635b2f98a9dc8ef2043cbfb
parentf2c5482af4550e4506893db52f66e24c3d93d163 (diff)
gnu: coin3d: Use G-Expressions.
* gnu/packages/graphics.scm (coin3d) <source>, <arguments>: Use G-Expressions. Change-Id: I79a77bda6fc919d9c3b80e77e38855824e81f6e6 Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/graphics.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ebbc705cfc..f866318289 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1967,28 +1967,26 @@ or by subtracting one shape from the other.")
(base32 "1ayg0hl8wanhadahm5xbghghxw1qjwqbrs3dl3ngnff027hsyf8p"))
(modules '((guix build utils)))
(snippet
- '(begin
- ;; Delete binaries
- (for-each delete-file
- '("cfg/csubst.exe"
- "cfg/wrapmsvc.exe"))
- ;; Delete references to packaging tool cpack. Otherwise the build
- ;; fails with "add_subdirectory given source "cpack.d" which is not
- ;; an existing directory."
- (substitute* "CMakeLists.txt"
- ((".*cpack.d.*") ""))
- #t))))
+ #~(begin
+ ;; Delete binaries
+ (for-each delete-file
+ '("cfg/csubst.exe"
+ "cfg/wrapmsvc.exe"))
+ ;; Delete references to packaging tool cpack. Otherwise the build
+ ;; fails with "add_subdirectory given source "cpack.d" which is not
+ ;; an existing directory."
+ (substitute* "CMakeLists.txt"
+ ((".*cpack.d.*") ""))))))
(build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
+ (string-append "-DBOOST_ROOT="
+ #$(this-package-input "boost")))))
(native-inputs
(list doxygen graphviz))
(inputs
(list boost freeglut glew))
- (arguments
- `(#:configure-flags
- (list
- "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
- (string-append "-DBOOST_ROOT="
- (assoc-ref %build-inputs "boost")))))
(home-page "https://github.com/coin3d/coin")
(synopsis
"High-level 3D visualization library with Open Inventor 2.1 API")