summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 23:29:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 23:50:26 +0000
commitabedc7444e15b99d9f0553de7051fe15398ff2d6 (patch)
tree132863dd06bf58a301f64aa8cf689f8f0b1b57ab
parentfe43dfb5c3e34ec1064cda889261d93a2d6196d2 (diff)
gnu: go-github-com-multiformats-go-multiaddr-net: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-multiformats-go-multiaddr-net): Move from here ... * gnu/packages/golang-web.scm (go-github-com-multiformats-go-multiaddr-net): ... to here. Change-Id: Ie7d35cae682e753ed5d08abdb5478c7d0c0bd4fa
-rw-r--r--gnu/packages/golang-web.scm43
-rw-r--r--gnu/packages/golang.scm38
2 files changed, 43 insertions, 38 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 5d606d9731..99210d8448 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1280,6 +1280,49 @@ following:
@end itemize\n")
(license license:expat))))
+(define-public go-github-com-multiformats-go-multiaddr-net
+ ;; This commit is from <2018-10-01> and associated with GX package manager,
+ ;; since that time the project has changed versing stile and GX is dropped.
+ ;; The latest versioned tag is v0.1.5 <2020-04-30>. The project is archved
+ ;; on <2021-10-05>.
+ (let ((commit "1cb9a0e8a6de3c8a10f6cee60d01d793603c4f7e")
+ (revision "0"))
+ (package
+ (name "go-github-com-multiformats-go-multiaddr-net")
+ (version (git-version "1.6.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-multiaddr-net")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ypgi47xdz3bh8lh7f8cmk7w3ql9g4izx5l3kzdg9gda1xn5zxq3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; TODO: Tests fail because they try to access the network.
+ #:tests? #f
+ #:import-path "github.com/multiformats/go-multiaddr-net"))
+ (native-inputs
+ (list go-github-com-gxed-hashland-keccakpg
+ go-github-com-minio-blake2b-simd
+ go-github-com-minio-sha256-simd
+ go-github-com-mr-tron-base58
+ go-github-com-multiformats-go-multiaddr
+ go-github-com-multiformats-go-multihash
+ go-github-com-spaolacci-murmur3
+ go-golang-org-x-crypto))
+ (home-page "https://github.com/multiformats/go-multiaddr-net")
+ (synopsis "Multiaddress net tools")
+ (description
+ "This package provides Multiaddr specific versions of common functions
+in stdlib's @command{net} package. This means wrappers of standard net
+symbols like @command{net.Dial} and @command{net.Listen}, as well as
+conversion to and from @command{net.Addr}.")
+ (license license:expat))))
+
(define-public go-github-com-nwidger-jsoncolor
(package
(name "go-github-com-nwidger-jsoncolor")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 557ffd144f..6a244152d5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5176,44 +5176,6 @@ maps, slices, or pointers, and copy their data as well instead of just their
references.")
(license license:expat)))
-(define-public go-github-com-multiformats-go-multiaddr-net
- (let ((commit "1cb9a0e8a6de3c8a10f6cee60d01d793603c4f7e")
- (revision "0"))
- (package
- (name "go-github-com-multiformats-go-multiaddr-net")
- (version (git-version "1.6.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/multiformats/go-multiaddr-net")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ypgi47xdz3bh8lh7f8cmk7w3ql9g4izx5l3kzdg9gda1xn5zxq3"))))
- (build-system go-build-system)
- (arguments
- (quote (#:import-path "github.com/multiformats/go-multiaddr-net"
- ;; TODO: Tests fail because they try to access the network.
- #:tests? #f)))
- (native-inputs
- (list go-github-com-multiformats-go-multiaddr
- go-github-com-multiformats-go-multihash
- go-github-com-gxed-hashland-keccakpg
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-mr-tron-base58
- go-github-com-spaolacci-murmur3
- go-golang-org-x-crypto))
- (home-page "https://github.com/multiformats/go-multiaddr-net")
- (synopsis "Multiaddress net tools")
- (description "This package provides Multiaddr specific versions of
-common functions in stdlib's @command{net} package. This means wrappers of
-standard net symbols like @command{net.Dial} and @command{net.Listen}, as well
-as conversion to and from @command{net.Addr}.")
- (license license:expat))))
-
(define-public go-github-com-whyrusleeping-tar-utils
(let ((commit "8c6c8ba81d5c71fd69c0f48dbde4b2fb422b6dfc")
(revision "0"))