summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-16 12:00:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-16 12:00:53 +0200
commitdbc4587fb137313c6e4da4d4030d1ad4d166045a (patch)
treeb2b1ff8c866420f4d8e1a6a33fbd408f74f1a5c5
parente9393087fcb2550df9cd670a0288d81feeff8703 (diff)
gnu: Add prosody-muc-offline-delivery.
* gnu/packages/messaging.scm (prosody-muc-offline-delivery): New variable. Change-Id: I145ea713e5b12aef5f700669fe2ffc1e017322d2
-rw-r--r--gnu/packages/messaging.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9cc03b6d39..beb1cfea96 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1643,6 +1643,15 @@ Notifications.")))
(description "This module implements XEP-0363: it allows clients to
upload files over HTTP.")))
+(define-public prosody-muc-offline-delivery
+ (package
+ (inherit (prosody-module "mod_muc_offline_delivery"))
+ (synopsis "Deliver MUC messages to users who are not in the room")
+ (description "This module implements support for sending messages in a MUC
+to affiliated users who are not in the room. This is a custom extension by
+Tigase to allow push notifications from MUCs to users who are not currently
+connected.")))
+
(define-public prosody-smacks
(package
(inherit (prosody-module "mod_smacks"))