summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-14 14:17:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-14 14:51:59 +0100
commitec8eef5e7e4b6c871bd8a9938ae64f6dd1277a3c (patch)
tree303fcecca92ee249a8d29bf68bcfd6507836d879
parent42b4580f6bfcaab009a56e679bd6f3c408ef03c9 (diff)
gnu: go-go-uber-org-atomic: Run tests only on x86-64.
Address the build issue on i686-linux as seen in CI <https://ci.guix.gnu.org/build/3395284/details>. * gnu/packages/golang-xyz.scm (go-go-uber-org-atomic): [arguments]: <#:tests?>: Only run on x86-64. Change-Id: Iab5a896be05d879f3552471d8789a11dba7826ce
-rw-r--r--gnu/packages/golang-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 91ec868a58..fcb352148c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3201,6 +3201,14 @@ similar string with weeks or days too.")
(build-system go-build-system)
(arguments
(list
+ ;; XXX: Disable failing tests on non-x86-64 architecture, see
+ ;; <https://github.com/uber-go/atomic/issues/164>.
+ ;;
+ ;; go.uber.org/atomic/uintptr_test.go:72:30: cannot convert
+ ;; math.MaxUint64 (untyped int constant 18446744073709551615) to type
+ ;; uintptr
+ #:tests? (and (not (%current-target-system))
+ (target-x86-64?))
#:import-path "go.uber.org/atomic"))
(native-inputs
(list go-github-com-stretchr-testify go-github-com-davecgh-go-spew))