summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2022-08-25 15:38:33 -0400
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-13 23:06:57 +0100
commitef9a2f9e91d37c0d93e689eb26ebeb6483655968 (patch)
tree12ebd8326118f8a8ab2dd088420e5ba44bdbe40d
parent56549cad7c438d4f7c74e28e3c68b6817ea24e14 (diff)
gnu: Add gnudatalanguage.
* gnu/packages/data-language.scm: New file. * gnu/packages/data-language.scm (gnudatalanguage): New variable. * gnu/local.mk: Add gnu/packages/data-language.scm to scope. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Icf830df85ed8e6f067344af96dbb7d202e677dee
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/data-language.scm90
2 files changed, 91 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e08b0d1c75..a05c92696c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -221,6 +221,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/cybersecurity.scm \
%D%/packages/cyrus-sasl.scm \
%D%/packages/darwin.scm \
+ %D%/packages/data-language.scm \
%D%/packages/databases.scm \
%D%/packages/datamash.scm \
%D%/packages/datastructures.scm \
diff --git a/gnu/packages/data-language.scm b/gnu/packages/data-language.scm
new file mode 100644
index 0000000000..e779832dd3
--- /dev/null
+++ b/gnu/packages/data-language.scm
@@ -0,0 +1,90 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages data-language)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages c)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages geo)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages onc-rpc)
+ #:use-module (gnu packages plotutils)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages wxwidgets)
+ #:use-module (gnu packages xml))
+
+(define-public gnudatalanguage
+ (package
+ (name "gnudatalanguage")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnudatalanguage/gdl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bb3nin3qrzx2dwdk08vffp4bblrcpv6vv1ybaj499qhqcpqpc12"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list python python-numpy))
+ (inputs
+ (list eccodes
+ eigen
+ expat
+ fftw
+ fftwf
+ glpk
+ graphicsmagick
+ gsl
+ hdf4-alt
+ hdf5
+ libgeotiff
+ libjpeg-turbo
+ libpng
+ libtiff
+ libtirpc
+ ncurses
+ netcdf
+ plplot
+ proj
+ readline
+ shapelib
+ udunits
+ wxwidgets
+ zlib))
+ (home-page "https://gnudatalanguage.github.io/")
+ (synopsis "Compiler for GDL, an IDL-compatible programming language")
+ (description
+ "GDL (GNU Data Language) is an incremental compiler compatible with
+IDL (Interactive Data Language) and to some extent with PV-WAVE. Together
+with its library routines it serves as a tool for data analysis and
+visualization in such disciplines as astronomy, geosciences and medical
+imaging.")
+ (license license:gpl2+)))