summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-03-22 20:12:28 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-23 09:35:25 +0000
commitf285a968b1219ae748fcab918b17285e741422c2 (patch)
tree96d63042517d2075f39442ef295711c7770bce29
parentf6f4c71df5558b168fe7a313522af7ea5fe2d0dc (diff)
gnu: python-box: Update to 7.1.1.
* gnu/packages/python-xyz.scm (python-box): Update to 7.1.1. [source]: Download from github since pypi tarball does not contain all test files. [build-system]: Use pyproject-build-system. [propagated-inputs]: Remove python-toml; add python-tomli and python-tomli-w. [native-inputs]: Add python-cython, python-pytest, and python-wheel. Change-Id: Ia39063054821e75768b1d9a5c937eab432e7c59e Reviewed-by: Munyoki Kilyungi <me@bonfacemunyoki.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 14 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eec7586d3f..aad89d251e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -108,7 +108,7 @@
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021, 2022, 2023 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
;;; Copyright © 2021, 2022 Pradana Aumars <paumars@courrier.dev>
-;;; Copyright © 2021, 2022, 2023 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021–2024 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
@@ -33544,17 +33544,24 @@ and powerful way to handle real-world data, featuring:
(define-public python-box
(package
(name "python-box")
- (version "5.3.0")
+ (version "7.1.1")
(source
+ ;; The PyPI tarball does not contain all test files.
(origin
- (method url-fetch)
- (uri (pypi-uri "python-box" version))
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/cdgriffith/Box")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0jhrdif57khx2hsw1q6a9x42knwcvq8ijgqyq1jmll6y6ifyzm2f"))))
- (build-system python-build-system)
+ "1v8s6wji17fh87nvamzysvxi8f51h6szh6h6dxvids56gg5zc553"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-msgpack python-ruamel.yaml python-toml))
+ (list python-msgpack python-ruamel.yaml python-tomli python-tomli-w))
+ (native-inputs
+ (list python-cython python-pytest python-wheel))
(home-page "https://github.com/cdgriffith/Box")
(synopsis "Advanced Python dictionaries with dot notation access")
(description