summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-04-09 12:22:34 +0200
committerChristopher Baines <mail@cbaines.net>2024-04-15 10:14:06 +0100
commitf2c5482af4550e4506893db52f66e24c3d93d163 (patch)
tree23b031eecbc3af2e4888efa5da36412450002ead
parent84a88f5ed96c8ec5781fc0f428d22380df1b1f14 (diff)
gnu: coin3D: Rename to coin3d.
* gnu/packages/graphics.scm (coin3d): New Variable. (coin3D): Define as deprecated. (coin3D-4): Point to coin3d. * gnu/packages/engineering.scm (freecad): Use coin3d instead of coin3D. * gnu/packages/python-xyz.scm (python-pivy): Ditto. * gnu/packages/qt.scm (soqt): Ditto. Change-Id: I4e83e25e80c512350f38024847891eac14723f26 Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/engineering.scm2
-rw-r--r--gnu/packages/graphics.scm9
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/qt.scm2
4 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6f42d674e5..7a60036c28 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2816,7 +2816,7 @@ comments.")))
swig))
(inputs
(list boost
- coin3D
+ coin3d
double-conversion
eigen
fmt
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index a63629823a..ebbc705cfc 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1951,9 +1951,9 @@ or by subtracting one shape from the other.")
(home-page "https://www.opencsg.org/")
(license license:gpl2))))
-(define-public coin3D
+(define-public coin3d
(package
- (name "coin3D")
+ (name "coin3d")
(version "4.0.0")
(source
(origin
@@ -2001,7 +2001,10 @@ library for 3D visualization and visual simulation software in the scientific
and engineering community.")
(license license:bsd-3)))
-(define-deprecated coin3D-4 coin3D)
+(define-deprecated coin3D coin3d)
+(export coin3D)
+
+(define-deprecated coin3D-4 coin3d)
(export coin3D-4)
(define-public skia
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 92566abfed..44c709a880 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32421,7 +32421,7 @@ used to retry a function a given number of times.")
libice
soqt
glew
- coin3D))
+ coin3d))
(home-page "https://github.com/coin3d/pivy")
(synopsis "Python bindings to Coin3D")
(description
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 198325c03a..8fc3b3b0e8 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -5116,7 +5116,7 @@ configurable also via HTTP.")
(native-inputs
(list pkg-config cmake))
(inputs
- (list qtbase-5 coin3D))
+ (list qtbase-5 coin3d))
(home-page "https://github.com/coin3d/soqt")
(synopsis "Qt GUI component toolkit library for Coin")
(description "SoQt is a Qt GUI component toolkit library for Coin. It is