summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-24 22:02:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-01-24 22:02:54 +0200
commit143e0fde17ee739ab9c87a15485cae37461d8ef9 (patch)
tree8fc7408d4f501ca77bdf5a5f9649025df99c643a
parent54abe5cb8163ba052de2497f4b60f89d17933225 (diff)
gnu: global: Adjust order of phases.
* gnu/packages/code.scm (global)[arguments]: Adjust the order of the phases so that they get read in the correct order. Change-Id: I149ccd249821c64aa5a508048d995e9963ea4c08
-rw-r--r--gnu/packages/code.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index b11a86d5cc..c27da995b4 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -217,22 +217,6 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(substitute* "globash/globash.in"
(("/bin/echo")
(search-input-file inputs "bin/echo")))))
- (add-after 'post-install 'install-plugins
- (lambda _
- (with-directory-excursion "plugin-factory"
- (invoke "make" "install"))))
- (add-before 'install 'dont-install-to-/var
- (lambda _
- (substitute* "gozilla/Makefile"
- (("DESTDIR\\)\\$\\{localstatedir\\}")
- "TMPDIR)"))))
- (add-after 'install-plugins 'wrap-program
- (lambda _
- (wrap-program
- (string-append #$output
- "/share/gtags/script/pygments_parser.py")
- `("GUIX_PYTHONPATH" ":" prefix
- (,(getenv "GUIX_PYTHONPATH"))))))
(add-after 'install 'post-install
(lambda _
;; Install the plugin files in the right place.
@@ -250,7 +234,23 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(rename-file (string-append data "/gtags.vim")
(string-append vim "/gtags.vim"))
(rename-file (string-append data "/gtags-cscope.vim")
- (string-append vim "/gtags-cscope.vim"))))))))
+ (string-append vim "/gtags-cscope.vim")))))
+ (add-after 'post-install 'install-plugins
+ (lambda _
+ (with-directory-excursion "plugin-factory"
+ (invoke "make" "install"))))
+ (add-before 'install 'dont-install-to-/var
+ (lambda _
+ (substitute* "gozilla/Makefile"
+ (("DESTDIR\\)\\$\\{localstatedir\\}")
+ "TMPDIR)"))))
+ (add-after 'install-plugins 'wrap-program
+ (lambda _
+ (wrap-program
+ (string-append #$output
+ "/share/gtags/script/pygments_parser.py")
+ `("GUIX_PYTHONPATH" ":" prefix
+ (,(getenv "GUIX_PYTHONPATH")))))))))
(inputs
(list bash-minimal ; for wrap-program
coreutils