summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-23 11:19:47 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-23 11:24:37 -0500
commit28e651d1f6c435559b8a7d32aa412d979ec7767d (patch)
treea554676e2fb8a069a00de2ee19bad61caffe8afe
parentb1106d32d8dad02d9a42f6309dc743889f33379f (diff)
gnu: imagemagick: Update to 6.9.13-5.
This is a follow-up to ac658511ae ("gnu: imagemagick: Update to 6.9.12-91."), which patch didn't apply cleanly. * gnu/packages/imagemagick.scm (imagemagick/stable): Update to 6.9.13-5. [source]: Remove patch. [configure-flags]: Specify correct --with-gs-font-dir location. [native-inputs]: Add zstd. * gnu/packages/patches/imagemagick-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. * gnu/packages/imagemagick.scm (imagemagick): Update to 6.9.13-5. Change-Id: Ic3ab5ea821de91fb18b80325414444e02e7eecb0
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/imagemagick.scm31
-rw-r--r--gnu/packages/patches/imagemagick-fix-tests.patch23
3 files changed, 17 insertions, 38 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e5c73d7ae2..4f41e14867 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1473,7 +1473,6 @@ dist_patch_DATA = \
%D%/packages/patches/idris-test-ffi008.patch \
%D%/packages/patches/igraph-fix-varargs-integer-size.patch \
%D%/packages/patches/ilmbase-fix-tests.patch \
- %D%/packages/patches/imagemagick-fix-tests.patch \
%D%/packages/patches/inkscape-poppler-compat.patch \
%D%/packages/patches/instead-use-games-path.patch \
%D%/packages/patches/intltool-perl-compatibility.patch \
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index cf6b6d5135..884fa87555 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -65,23 +65,25 @@
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.12-91")
+ (version "6.9.13-5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
- (patches
- (search-patches "imagemagick-fix-tests.patch"))))
+ "1j1chkw33vjc37509vdwss28qywfvckvs73pvscldj8d0wnwypa8"))))
(build-system gnu-build-system)
(arguments
(list
- #:configure-flags #~(list "--with-frozenpaths" "--without-gcc-arch"
-
- ;; Do not embed the build date in binaries.
- "--enable-reproducible-build")
+ #:configure-flags
+ #~(list "--with-frozenpaths"
+ "--without-gcc-arch"
+ (string-append "--with-gs-font-dir="
+ (search-input-directory %build-inputs
+ "share/fonts/type1"))
+ ;; Do not embed the build date in binaries.
+ "--enable-reproducible-build")
#:phases
#~(modify-phases %standard-phases
(add-before 'build 'pre-build
@@ -124,8 +126,11 @@
libxml2
pango
xz
- zlib))
- (native-inputs (list pkg-config))
+ zlib
+ zstd))
+ (native-inputs
+ (list font-ghostscript
+ pkg-config))
(outputs '("out"
"doc")) ; 26 MiB of HTML documentation
(home-page "https://www.imagemagick.org/")
@@ -146,16 +151,14 @@ text, lines, polygons, ellipses and Bézier curves.")
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.12-91")
+ (version "6.9.13-5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
- (patches
- (search-patches "imagemagick-fix-tests.patch"))))))
+ "1j1chkw33vjc37509vdwss28qywfvckvs73pvscldj8d0wnwypa8"))))))
(define-public perl-image-magick
(package
diff --git a/gnu/packages/patches/imagemagick-fix-tests.patch b/gnu/packages/patches/imagemagick-fix-tests.patch
deleted file mode 100644
index dc6ee9852f..0000000000
--- a/gnu/packages/patches/imagemagick-fix-tests.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 696d8735e05688d0162b769f37b0d75205ab2a97 Mon Sep 17 00:00:00 2001
-From: Saku Laesvuori <saku@laesvuori.fi>
-Date: Thu, 20 Jul 2023 19:14:43 +0300
-Subject: [PATCH] Fix tests
-
----
- Magick++/demo/demo.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Magick++/demo/demo.cpp b/Magick++/demo/demo.cpp
-index 14721dbcd..12cc3b10c 100644
---- a/Magick++/demo/demo.cpp
-+++ b/Magick++/demo/demo.cpp
-@@ -477,7 +477,7 @@ int main( int /*argc*/, char ** argv)
- montageOpts.compose( OverCompositeOp );
- montageOpts.backgroundColor( "#ffffff" );
- montageOpts.pointSize( 18 );
-+ montageOpts.font(MAGICK_FONT);
- montageOpts.fillColor( "#600" );
- montageOpts.strokeColor( Color() );
- montageOpts.compose(OverCompositeOp);
---
-2.41.0